aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2018-10-11 13:44:34 +0200
committerGitHub <noreply@github.com>2018-10-11 13:44:34 +0200
commit960d4b29d79425115a49f00ab2d3c681615e683c (patch)
tree258a1e18be04ad95ea2701bbd49c49ad76b1a3da /meson.build
parentMerge pull request #10358 from yuwata/fix-10333 (diff)
parentmeson: use vars we already have defined in status (diff)
downloadsystemd-960d4b29d79425115a49f00ab2d3c681615e683c.tar.gz
systemd-960d4b29d79425115a49f00ab2d3c681615e683c.tar.bz2
systemd-960d4b29d79425115a49f00ab2d3c681615e683c.zip
Merge pull request #10334 from keszybz/nomempool
Use mempool only in progs linked to libsystemd-shared.so
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build13
1 files changed, 9 insertions, 4 deletions
diff --git a/meson.build b/meson.build
index 35b6ea0e3..6f1fa39e2 100644
--- a/meson.build
+++ b/meson.build
@@ -1383,7 +1383,7 @@ libjournal_core = static_library(
libsystemd_sym_path = '@0@/@1@'.format(meson.current_source_dir(), libsystemd_sym)
libsystemd = shared_library(
'systemd',
- 'src/systemd/sd-id128.h', # pick a header file at random to work around old meson bug
+ disable_mempool_c,
version : libsystemd_version,
include_directories : includes,
link_args : ['-shared',
@@ -1465,6 +1465,7 @@ subdir('test')
test_dlopen = executable(
'test-dlopen',
test_dlopen_c,
+ disable_mempool_c,
include_directories : includes,
link_with : [libbasic],
dependencies : [libdl],
@@ -1485,6 +1486,7 @@ foreach tuple : [['myhostname', 'ENABLE_NSS_MYHOSTNAME'],
nss = shared_library(
'nss_' + module,
'src/nss-@0@/nss-@0@.c'.format(module),
+ disable_mempool_c,
version : '2',
include_directories : includes,
# Note that we link NSS modules with '-z nodelete' so that mempools never get orphaned
@@ -2782,12 +2784,9 @@ subdir('shell-completion/zsh')
subdir('docs/sysvinit')
subdir('docs/var-log')
-# FIXME: figure out if the warning is true:
-# https://github.com/mesonbuild/meson/wiki/Reference-manual#install_subdir
install_subdir('factory/etc',
install_dir : factorydir)
-
install_data('xorg/50-systemd-user.sh',
install_dir : xinitrcdir)
install_data('modprobe.d/systemd.conf',
@@ -2984,6 +2983,10 @@ alt_time_epoch = run_command('date', '-Is', '-u', '-d',
status += [
'time epoch: @0@ (@1@)'.format(time_epoch, alt_time_epoch)]
+status += [
+ 'static libsystemd: @0@'.format(static_libsystemd),
+ 'static libudev: @0@'.format(static_libudev)]
+
# TODO:
# CFLAGS: ${OUR_CFLAGS} ${CFLAGS}
# CPPFLAGS: ${OUR_CPPFLAGS} ${CPPFLAGS}
@@ -3083,6 +3086,8 @@ foreach tuple : [
['debug mmap cache'],
['valgrind', conf.get('VALGRIND') == 1],
['trace logging', conf.get('LOG_TRACE') == 1],
+ ['link-udev-shared', get_option('link-udev-shared')],
+ ['link-systemctl-shared', get_option('link-systemctl-shared')],
]
if tuple.length() >= 2