aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-04-09 23:55:05 -0400
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-04-23 21:47:27 -0400
commit94e75a54097b32252ef86e9253a288db7529f1ea (patch)
treecddc53ebc24428981faa4df1c395621846bee80c /network
parentmeson: add unit installation symlinks (diff)
downloadsystemd-94e75a54097b32252ef86e9253a288db7529f1ea.tar.gz
systemd-94e75a54097b32252ef86e9253a288db7529f1ea.tar.bz2
systemd-94e75a54097b32252ef86e9253a288db7529f1ea.zip
meson: create dirs and touch /usr
This is the equivalent of $(INSTALL_DIRS) and install-touch-usr-hook. I did not bother to create the directories into which we install files, since they will be created anyway. v2: - remove bashism
Diffstat (limited to 'network')
-rw-r--r--network/meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/network/meson.build b/network/meson.build
index b578159b0..d2eb89ad4 100644
--- a/network/meson.build
+++ b/network/meson.build
@@ -6,4 +6,7 @@ if conf.get('ENABLE_NETWORKD', 0) == 1
'80-container-vz.network',
'99-default.link',
install_dir : networkdir)
+
+ meson.add_install_script('sh', '-c',
+ mkdir_p.format(sysconfdir + '/systemd/network'))
endif