summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorwiktor w brodlo <wiktor@brodlo.net>2011-07-25 19:12:41 +0000
committerwiktor w brodlo <wiktor@brodlo.net>2011-07-25 19:12:41 +0000
commita5ed416f9a7b826d2afbb1c45a5170b3143bf7e3 (patch)
tree4d22ddb59b2f70f46ab4f76bed5ade47912fa6d9
parent sys-block/open-iscsi: update manifest (diff)
downloadanaconda-overlay-a5ed416f9a7b826d2afbb1c45a5170b3143bf7e3.tar.gz
anaconda-overlay-a5ed416f9a7b826d2afbb1c45a5170b3143bf7e3.tar.bz2
anaconda-overlay-a5ed416f9a7b826d2afbb1c45a5170b3143bf7e3.zip
New versions of Fedora ebuilds
-rw-r--r--app-admin/firstboot/firstboot-1.119.ebuild32
-rw-r--r--app-admin/system-config-date/system-config-date-1.9.61.ebuild50
-rw-r--r--app-admin/system-config-users/system-config-users-1.2.105.ebuild52
-rw-r--r--app-cdr/isomd5sum/isomd5sum-1.0.7.ebuild17
-rw-r--r--dev-python/python-cryptsetup/python-cryptsetup-0.1.4.ebuild21
-rw-r--r--dev-python/python-meh/python-meh-0.11.ebuild35
-rw-r--r--dev-python/python-report/python-report-0.23.ebuild63
-rw-r--r--dev-python/python-slip/python-slip-0.2.17.ebuild28
-rw-r--r--dev-util/pykickstart/pykickstart-1.99.2.ebuild18
-rw-r--r--sys-block/open-iscsi/open-iscsi-2.0.872.ebuild106
10 files changed, 422 insertions, 0 deletions
diff --git a/app-admin/firstboot/firstboot-1.119.ebuild b/app-admin/firstboot/firstboot-1.119.ebuild
new file mode 100644
index 0000000..825e9da
--- /dev/null
+++ b/app-admin/firstboot/firstboot-1.119.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/firstboot/firstboot-1.4.19.ebuild,v 1.3 2007/10/15 09:35:28 dberkholz Exp $
+
+EAPI=3
+inherit python distutils rpm
+
+# Revision of the RPM. Shouldn't affect us, as we're just grabbing the source
+# tarball out of it
+RPMREV="1"
+
+DESCRIPTION="Initial system configuration utility"
+HOMEPAGE="http://fedoraproject.org/wiki/FirstBoot"
+SRC_URI="http://download.fedora.redhat.com/pub/fedora/linux/releases/15/Everything/source/SRPMS/${P}-${RPMREV}.fc15.src.rpm"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 amd64"
+IUSE="gtk"
+RDEPEND="
+ gtk? ( =dev-python/pygtk-2* )
+ dev-python/rhpl
+ app-admin/system-config-users
+ app-admin/system-config-date
+ sys-libs/libuser
+ dev-python/python-ethtool"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+PDEPEND="app-admin/system-config-keyboard"
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}
diff --git a/app-admin/system-config-date/system-config-date-1.9.61.ebuild b/app-admin/system-config-date/system-config-date-1.9.61.ebuild
new file mode 100644
index 0000000..45a85ce
--- /dev/null
+++ b/app-admin/system-config-date/system-config-date-1.9.61.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2004-2010 Sabayon
+# Distributed under the terms of the GNU General Public License v2
+# $
+
+EAPI="2"
+inherit python base
+
+DESCRIPTION="The system-config-date tool lets you set the date and time of your machine."
+HOMEPAGE="http://fedoraproject.org/wiki/SystemConfig/date"
+SRC_URI="https://fedorahosted.org/released/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-1"
+KEYWORDS="amd64 x86"
+SLOT="0"
+IUSE="gtk"
+
+# FIXME: would also require a dependency against anaconda
+DEPEND="app-text/docbook-xml-dtd
+ app-text/docbook-sgml-dtd
+ app-text/gnome-doc-utils
+ app-text/rarian
+ dev-libs/newt
+ dev-util/desktop-file-utils
+ dev-util/intltool
+ sys-devel/gettext"
+
+# also net-misc/ntp would be a soft-dependency
+# but code is redhat-centric, so we won't really
+# let user use this crap
+# net-misc/ntp
+RDEPEND="dev-libs/newt
+ dev-python/python-slip
+ dev-python/rhpl
+ gtk? ( dev-python/pygtk:2
+ dev-python/libgnomecanvas-python
+ x11-themes/hicolor-icon-theme )"
+
+src_install() {
+ base_src_install
+
+ # removing .desktop file, not advertising this, it is
+ # only needed by app-admin/anaconda
+ rm -rf "${D}/usr/share/"{man,applications}
+ rm -rf "${D}/etc/"{pam.d,security}
+ rm -rf "${D}/usr/bin"
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}
diff --git a/app-admin/system-config-users/system-config-users-1.2.105.ebuild b/app-admin/system-config-users/system-config-users-1.2.105.ebuild
new file mode 100644
index 0000000..7a3be47
--- /dev/null
+++ b/app-admin/system-config-users/system-config-users-1.2.105.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2004-2010 Sabayon
+# Distributed under the terms of the GNU General Public License v2
+# $
+
+EAPI="2"
+inherit python base
+
+DESCRIPTION="The system-config-users tool lets you manage the users and groups on your computer."
+HOMEPAGE="http://fedoraproject.org/wiki/SystemConfig/users"
+SRC_URI="https://fedorahosted.org/released/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-1"
+KEYWORDS="amd64 x86"
+SLOT="0"
+IUSE="X"
+
+DEPEND="dev-util/desktop-file-utils
+ dev-util/intltool
+ sys-apps/findutils
+ sys-devel/gettext"
+
+# FIXME: would require rpm-python
+RDEPEND="
+ X? ( >=dev-python/pygtk-2.6
+ x11-misc/xdg-utils
+ )
+ >=sys-libs/libuser-0.56
+ sys-libs/cracklib
+ sys-process/procps"
+
+PATCHES=( "${FILESDIR}/${PN}-kill-rpm.patch" )
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}
+
+# FIXME: this package should depend against sys-apps/usermode
+# which has been removed from Portage in May, 2009.
+# If you intend to provide a full package in future (and not
+# just stuff required by app-admin/anaconda, please consider
+# to re-add sys-apps/usermode (version bumping, QA checking)
+# and remove the hackish code in src_install below
+src_install() {
+ base_src_install
+
+ # See FIXME above
+ rm -rf "${D}/usr/share/"{man,applications}
+ rm -rf "${D}/etc/"{pam.d,sysconfig,security}
+ rm -rf "${D}/etc/sysconfig"
+ rm -rf "${D}/usr/bin"
+ find "${D}" -name "*.pyc" | xargs rm -f
+}
diff --git a/app-cdr/isomd5sum/isomd5sum-1.0.7.ebuild b/app-cdr/isomd5sum/isomd5sum-1.0.7.ebuild
new file mode 100644
index 0000000..00cdf9e
--- /dev/null
+++ b/app-cdr/isomd5sum/isomd5sum-1.0.7.ebuild
@@ -0,0 +1,17 @@
+# Copyright 2004-2009 Sabayon Linux
+# Distributed under the terms of the GNU General Public License v2
+# $
+
+EAPI="2"
+inherit base
+
+DESCRIPTION="isomd5sum provides a way of making use of the ISO9660 application data area to store md5sum data about the iso"
+HOMEPAGE="http://fedorahosted.org/releases/i/s/isomd5sum"
+SRC_URI="https://fedorahosted.org/releases/i/s/isomd5sum/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+DEPEND=""
+RDEPEND=""
diff --git a/dev-python/python-cryptsetup/python-cryptsetup-0.1.4.ebuild b/dev-python/python-cryptsetup/python-cryptsetup-0.1.4.ebuild
new file mode 100644
index 0000000..2c2c0a3
--- /dev/null
+++ b/dev-python/python-cryptsetup/python-cryptsetup-0.1.4.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+EGIT_REPO_URI="git://git.fedorahosted.org/python-cryptsetup.git"
+EGIT_COMMIT="${P}-1"
+
+inherit distutils git eutils
+
+DESCRIPTION="Python bindings for Network Security Services (NSS)"
+HOMEPAGE="http://git.fedorahosted.org/git/?p=python-cryptsetup.git"
+SRC_URI=""
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-fs/cryptsetup"
+RDEPEND="${DEPEND}"
diff --git a/dev-python/python-meh/python-meh-0.11.ebuild b/dev-python/python-meh/python-meh-0.11.ebuild
new file mode 100644
index 0000000..74fd4a6
--- /dev/null
+++ b/dev-python/python-meh/python-meh-0.11.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+EGIT_REPO_URI="git://git.fedorahosted.org/python-meh.git"
+EGIT_COMMIT="r${PV}-1"
+inherit distutils git eutils
+
+DESCRIPTION="Python exception handling library"
+HOMEPAGE="http://git.fedoraproject.org/git/python-meh.git?p=python-meh.git;a=summary"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk"
+
+COMMON_DEPEND="dev-util/intltool
+ sys-devel/gettext"
+DEPEND="${COMMON_DEPEND}"
+# FIXME: missing RDEPENDs: rpm, yum
+RDEPEND="${COMMON_DEPEND}
+ dev-libs/newt
+ gtk? ( dev-python/pygtk:2 )
+ dev-python/dbus-python
+ dev-python/python-report
+ net-misc/openssh"
+
+src_prepare() {
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-keep_exc_win_above.patch"
+ distutils_src_prepare
+}
diff --git a/dev-python/python-report/python-report-0.23.ebuild b/dev-python/python-report/python-report-0.23.ebuild
new file mode 100644
index 0000000..7bbd08b
--- /dev/null
+++ b/dev-python/python-report/python-report-0.23.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="2"
+
+EGIT_REPO_URI="git://git.fedorahosted.org/report.git"
+EGIT_COMMIT="${PV}"
+inherit base git autotools eutils
+
+DESCRIPTION="Provides a single configurable problem/bug/issue reporting API."
+HOMEPAGE="http://git.fedoraproject.org/git/?p=report.git;a=summary"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/rpm
+ net-misc/curl"
+RDEPEND="dev-libs/openssl
+ net-misc/curl
+ dev-libs/libxml2"
+
+src_prepare() {
+
+ epatch "${FILESDIR}"/${P}-sabayon-defaults.patch
+ epatch "${FILESDIR}"/${P}-disable-rpm.patch
+ epatch "${FILESDIR}"/${P}-fix-version-detection.patch
+
+ eautoreconf || die "cannot run eautoreconf"
+ autoreconf -i || die "wtf"
+ eautomake || die "cannot run eautomake"
+}
+
+src_configure() {
+ econf --prefix=/usr || die "configure failed"
+}
+
+src_compile() {
+ # workaround crappy build system
+ mkdir -p "${S}/python/report/templates/RHEL-template/bugzillaCopy"
+ touch "${S}/python/report/templates/RHEL-template/bugzillaCopy/VERSION"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ base_src_install
+
+ # remove Red Hat stuff
+ rm "${D}"/etc/report.d/RHEL.ini
+ rm "${D}"/etc/report.d/dropbox.redhat.com.ini
+ rm "${D}"/etc/report.d/bugzilla.redhat.com.ini
+
+ # XXX: {not yet implemented} install Sabayon configuration
+ # cp "${FILESDIR}"/bugs.sabayon.org.ini "${D}/etc/report.d/"
+ find "${D}"/ -name "bugzilla-template" -type d | xargs rm -rf
+ find "${D}"/ -name "RHEL-template" -type d | xargs rm -rf
+ find "${D}"/ -name "strata-template" -type d | xargs rm -rf
+
+}
diff --git a/dev-python/python-slip/python-slip-0.2.17.ebuild b/dev-python/python-slip/python-slip-0.2.17.ebuild
new file mode 100644
index 0000000..4e2376a
--- /dev/null
+++ b/dev-python/python-slip/python-slip-0.2.17.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+inherit python distutils
+
+DESCRIPTION="The Simple Library for Python packages"
+HOMEPAGE="https://fedorahosted.org/python-slip/"
+SRC_URI="https://fedorahosted.org/released/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="gtk selinux"
+# TODO: split package?
+RDEPEND="selinux? ( sys-libs/libselinux )
+ dev-python/dbus-python
+ || ( sys-auth/polkit sys-auth/policykit )
+ dev-python/decorator
+ gtk? ( dev-python/pygtk )"
+
+src_compile() {
+ emake || die "cannot run make"
+ distutils_src_compile
+}
diff --git a/dev-util/pykickstart/pykickstart-1.99.2.ebuild b/dev-util/pykickstart/pykickstart-1.99.2.ebuild
new file mode 100644
index 0000000..40027c2
--- /dev/null
+++ b/dev-util/pykickstart/pykickstart-1.99.2.ebuild
@@ -0,0 +1,18 @@
+# Copyright 2004-2010 Sabayon
+# Distributed under the terms of the GNU General Public License v2
+# $
+
+EAPI="3"
+EGIT_COMMIT="r${PV}-1"
+EGIT_REPO_URI="git://git.fedorahosted.org/git/pykickstart.git"
+inherit base distutils git
+
+DESCRIPTION="pykickstart is a python library that is used for reading and writing kickstart files."
+HOMEPAGE="http://fedoraproject.org/wiki/Pykickstart"
+SRC_URI=""
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+RDEPEND="${RDEPEND} sys-devel/gettext"
diff --git a/sys-block/open-iscsi/open-iscsi-2.0.872.ebuild b/sys-block/open-iscsi/open-iscsi-2.0.872.ebuild
new file mode 100644
index 0000000..bdfe951
--- /dev/null
+++ b/sys-block/open-iscsi/open-iscsi-2.0.872.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+inherit distutils versionator linux-info eutils flag-o-matic autotools
+
+DESCRIPTION="Open-iSCSI is a high performance, transport independent, multi-platform implementation of RFC3720"
+HOMEPAGE="http://www.open-iscsi.org/"
+MY_PV="${PN}-$(replace_version_separator 2 "-" $MY_PV)"
+SRC_URI="mirror://kernel/linux/kernel/people/mnc/open-iscsi/releases/${MY_PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug slp"
+DEPEND="net-libs/openslp"
+RDEPEND="${DEPEND}
+ sys-apps/util-linux"
+
+S="${WORKDIR}/${MY_PV}"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ if [ $KV_PATCH -lt 15 ]; then
+ die "Sorry, your kernel must be 2.6.16-rc5 or newer!"
+ fi
+}
+
+src_prepare() {
+ export EPATCH_OPTS="-d${S}"
+ epatch "${FILESDIR}"/${PN}-2.0.872-makefile-cleanup.patch
+ epatch "${FILESDIR}"/${P}-glibc212.patch
+ epatch "${FILESDIR}"/${P}-slp.patch
+ epatch "${FILESDIR}"/${P}-omg-calling-configure.patch
+
+ # add RH patches, we need libiscsi for anaconda
+ epatch "${FILESDIR}"/redhat-${PV}/iscsi-initiator-utils-update-initscripts-and-docs.patch
+ epatch "${FILESDIR}"/redhat-${PV}/iscsi-initiator-utils-use-var-for-config.patch
+ epatch "${FILESDIR}"/redhat-${PV}/iscsi-initiator-utils-use-red-hat-for-name.patch
+ epatch "${FILESDIR}"/redhat-${PV}/iscsi-initiator-utils-add-libiscsi.patch
+ epatch "${FILESDIR}"/redhat-${PV}/iscsi-initiator-utils-disable-isns-for-lib.patch
+ epatch "${FILESDIR}"/redhat-${PV}/iscsi-initiator-utils-fix-lib-sysfs-init.patch
+
+ if use slp; then
+ # workaround bug with lslp
+ cd "${S}"/utils/open-isns || die
+ eautoreconf
+ sed -i "s:-lisns:-lisns -lslp:g" "${S}"/usr/Makefile || die
+ fi
+}
+
+src_configure() {
+ einfo "Configuring userpsace"
+ cd "${S}/utils/open-isns" || die
+ econf $(use_with slp) || die
+}
+
+src_compile() {
+ use debug && append-flags -DDEBUG_TCP -DDEBUG_SCSI
+ einfo "Building userspace"
+ cd "${S}" || die
+ CFLAGS="" emake OPTFLAGS="${CFLAGS}" user || die "emake failed"
+}
+
+src_install() {
+ # build system is broken...
+ emake DESTDIR="${D}" sbindir="/usr/sbin" install_user || die "emake install_user failed"
+ # this doesn't get installed
+ dosbin usr/iscsistart
+
+ einfo "Installing configuration"
+ insinto /etc/iscsi
+ doins etc/iscsid.conf
+ newins "${FILESDIR}"/initiatorname.iscsi initiatorname.iscsi.example
+ insinto /etc/iscsi/ifaces
+ doins etc/iface.example
+
+ newconfd "${FILESDIR}"/iscsid-conf.d iscsid
+ newinitd "${FILESDIR}"/iscsid-2.0.871-r1.init.d iscsid
+
+ keepdir /var/db/iscsi
+ fperms 700 /var/db/iscsi
+ fperms 600 /etc/iscsi/iscsid.conf
+
+ einfo "Installing libiscsi"
+ dodir /usr/$(get_libdir)
+ exeinto /usr/$(get_libdir)
+ doexe "${S}"/libiscsi/libiscsi.so.0
+ dosym libiscsi.so.0 /usr/$(get_libdir)/libiscsi.so
+
+ dodir /usr/include
+ insinto /usr/include
+ doins "${S}"/libiscsi/libiscsi.h
+
+ cd "${S}"/libiscsi || die
+ distutils_src_install
+
+}
+
+pkg_postinst() {
+ in='/etc/iscsi/initiatorname.iscsi'
+ if [ ! -f "${ROOT}${in}" -a -f "${ROOT}${in}.example" ]; then
+ cp -f "${ROOT}${in}.example" "${ROOT}${in}"
+ fi
+}