aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 96e3763..88d9363 100644
--- a/Makefile
+++ b/Makefile
@@ -10,6 +10,14 @@ file_hook.so: file_hook.o
file_hook.o: src/hook_lib/file_hook.c
cc -Wall -fPIC -o file_hook.o -c src/hook_lib/file_hook.c
+install:
+ mkdir -p "${DESTDIR}/usr/lib/"
+ cp file_hook.so "${DESTDIR}/usr/lib/"
+ cp -R src/autodep "${DESTDIR}/usr/lib/"
+ cp -R portage_with_autodep "${DESTDIR}/usr/lib/"
+
+ mkdir -p "${DESTDIR}/usr/bin/"
+ cp hookfs emerge_strict "${DESTDIR}/usr/bin/"
clean:
rm -f hookfs file_hook.o file_hook.so