summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaymon <darwinskernel@gmail.com>2022-07-18 10:37:16 -0400
committerMike Gilbert <floppym@gentoo.org>2022-09-17 23:21:01 -0400
commit63accc51997bc0433f2ce3c9f637a656eac649e7 (patch)
tree7ef010a57a8f4402fcf99ca878c5f6e6434d2d53
parentMakefile: simplify /sbin symlink for usrmerge (diff)
downloadbaselayout-63accc51997bc0433f2ce3c9f637a656eac649e7.tar.gz
baselayout-63accc51997bc0433f2ce3c9f637a656eac649e7.tar.bz2
baselayout-63accc51997bc0433f2ce3c9f637a656eac649e7.zip
Relax checks on KEEPDIR when directories are mounted fs
My use case for this is in containers (mkosi with systemd-nspawn in my case) Closes: https://github.com/gentoo/baselayout/pull/2 Signed-off-by: Paymon <darwinskernel@gmail.com> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index e0266d2a..230acbc5 100644
--- a/Makefile
+++ b/Makefile
@@ -76,7 +76,7 @@ layout-dirs:
# Create base filesytem layout
for x in $(KEEP_DIRS) ; do \
test -e $(DESTDIR)$$x/.keep && continue ; \
- $(INSTALL_DIR) $(DESTDIR)$$x || exit $$? ; \
+ $(INSTALL_DIR) $(DESTDIR)$$x ; \
touch $(DESTDIR)$$x/.keep || echo "ignoring touch failure; mounted fs?" ; \
done