summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-22 12:38:47 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-22 12:38:47 +0200
commitd2a6c20c99bad1a205d8e262fc7c867922c5d506 (patch)
treeba3a8d7854c291a58ac643f416797d9b15c2b8c1 /dev-cpp
parentDrop obsolete Sources unavailable (diff)
downloadbetagarden-d2a6c20c99bad1a205d8e262fc7c867922c5d506.tar.gz
betagarden-d2a6c20c99bad1a205d8e262fc7c867922c5d506.tar.bz2
betagarden-d2a6c20c99bad1a205d8e262fc7c867922c5d506.zip
dev-cpp/curlpp: Fix SRC_URI
Package-Manager: portage-2.2.21 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/curlpp/Manifest2
-rw-r--r--dev-cpp/curlpp/curlpp-0.7.3.ebuild (renamed from dev-cpp/curlpp/curlpp-0.7.2.ebuild)16
2 files changed, 9 insertions, 9 deletions
diff --git a/dev-cpp/curlpp/Manifest b/dev-cpp/curlpp/Manifest
index faf02e6..b4715d2 100644
--- a/dev-cpp/curlpp/Manifest
+++ b/dev-cpp/curlpp/Manifest
@@ -1 +1 @@
-DIST curlpp-0.7.2.tar.gz 472612 SHA256 b7af1b8d2bd5797538f88e247b3ccfc7f1e9fc5aa28259e4e026f796aec385fc
+DIST curlpp-0.7.3.tar.gz 200095 SHA256 b72093f221a9e2d0f7ce0bd0f846587835e01607a7bb0f106ff4317a8c30a81c SHA512 a006219e522c0764c7c7e66bd1934a525600bc567dd0bb3b871e6b8db35781380147d42d40a7a28ae530e72e99bc218147177cc797a91b15c6d1e91f98c851b2 WHIRLPOOL ec6f6511a726b4ced1bfe5722e19bcaa9ba2f15574517a17e81144019bdcd02f7adc00228d852d05c15a891a79945b87be3271bdebc82a929a7d6759d95bf1ca
diff --git a/dev-cpp/curlpp/curlpp-0.7.2.ebuild b/dev-cpp/curlpp/curlpp-0.7.3.ebuild
index 776583c..d2bd719 100644
--- a/dev-cpp/curlpp/curlpp-0.7.2.ebuild
+++ b/dev-cpp/curlpp/curlpp-0.7.3.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="2"
+EAPI=5
inherit autotools
DESCRIPTION="C++ bindings of libcurl"
-HOMEPAGE="http://rrette.com/textpattern/index.php?s=cURLpp"
-SRC_URI="http://rrette.com/files/curlpp/curlpp-0.7/${P}.tar.gz"
+HOMEPAGE="http://www.curlpp.org/"
+SRC_URI="https://github.com/jpbarrette/curlpp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
@@ -19,14 +19,14 @@ DEPEND="net-misc/curl"
RDEPEND="${DEPEND}"
src_prepare() {
- sed -i -e "s:@CURLPP_CFLAGS@:@CURLPP_CXXFLAGS@:" curlpp-config.in
+ sed -i -e "s:@CURLPP_CFLAGS@:@CURLPP_CXXFLAGS@:" curlpp-config.in || die
epatch "${FILESDIR}/disable-examples-build.patch" #example18 doesnt build
eautoreconf
}
src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- dodoc CHANGES AUTHORS TODO doc/guide.pdf
- insinto "/usr/share/${P}"
+ default
+ dodoc doc/guide.pdf
+ insinto /usr/share/${P}
doins examples/*
}