summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-07-08 01:27:28 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-07-08 01:27:28 +0200
commitc19f12fb4e9ebc0cdd0b49ef6c23161db9a5a953 (patch)
tree81627cea78d2db952ff1a3e75709f89d194e2b5f
parentLICENSE.txt: add (diff)
downloademacs-openrc-c19f12fb4e9ebc0cdd0b49ef6c23161db9a5a953.tar.gz
emacs-openrc-c19f12fb4e9ebc0cdd0b49ef6c23161db9a5a953.tar.bz2
emacs-openrc-c19f12fb4e9ebc0cdd0b49ef6c23161db9a5a953.zip
Makefile: add install target for local installations
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 513142e..62da177 100644
--- a/Makefile
+++ b/Makefile
@@ -17,3 +17,8 @@ clean:
.PHONY: compile
compile: openrc.elc
+
+.PHONY: install
+install: compile
+ $(EMACSCMD) \
+ --eval "(require 'package)" --eval "(package-install-file \"$(PWD)\")"