aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2024-05-20 21:04:26 +0200
committerUlrich Müller <ulm@gentoo.org>2024-05-20 21:04:26 +0200
commit01a51464f2e070073bb7c00cc57af00bb6d43088 (patch)
treed1c9f5ddccd9710b3f570b9ba3ccca4a5af0337f
parent26.3, 27.2, 28.2, 29.3: Fix build with mksh (diff)
downloademacs-patches-01a51464f2e070073bb7c00cc57af00bb6d43088.tar.gz
emacs-patches-01a51464f2e070073bb7c00cc57af00bb6d43088.tar.bz2
emacs-patches-01a51464f2e070073bb7c00cc57af00bb6d43088.zip
29.2: Remove patchset
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--emacs/29.2/01_all_sanity-check.patch13
-rw-r--r--emacs/29.2/02_all_epg-gpmsm.patch38
-rw-r--r--emacs/29.2/03_all_configure-decl.patch52
3 files changed, 0 insertions, 103 deletions
diff --git a/emacs/29.2/01_all_sanity-check.patch b/emacs/29.2/01_all_sanity-check.patch
deleted file mode 100644
index 6509cf7..0000000
--- a/emacs/29.2/01_all_sanity-check.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-https://bugs.gentoo.org/916180
-
---- emacs-29.1/Makefile.in
-+++ emacs-29.1/Makefile.in
-@@ -417,7 +417,7 @@
-
- sanity-check:
- @[ -f .no-advice-on-failure ] && exit 0; true
-- @v=$$(src/emacs${EXEEXT} --batch --eval \
-+ @v=$$(src/emacs${EXEEXT} --batch --quick --eval \
- '(progn (defun f (n) (if (= 0 n) 1 (* n (f (- n 1))))) (princ (f 10)))' \
- 2> /dev/null); \
- [ "X$$v" = "X3628800" ] && exit 0; \
diff --git a/emacs/29.2/02_all_epg-gpmsm.patch b/emacs/29.2/02_all_epg-gpmsm.patch
deleted file mode 100644
index 646798c..0000000
--- a/emacs/29.2/02_all_epg-gpmsm.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-Don't enable pinentry loopback mode for gpgsm
-Patch from master branch
-https://debbugs.gnu.org/67012
-
-commit e736a1b5a2aa2dd8dbaba32a408db70822fe434f
-Author: Ulrich Müller <ulm@gentoo.org>
-Date: Fri Nov 17 12:16:54 2023 +0100
-
- Don't enable pinentry loopback mode for gpgsm
-
---- a/doc/misc/epa.texi
-+++ b/doc/misc/epa.texi
-@@ -640,6 +640,9 @@ GnuPG Pinentry
- Emacs.
- @end enumerate
-
-+Note that loopback Pinentry does not work with @command{gpgsm},
-+therefore EasyPG will ignore this setting for it.
-+
- There are other options available to use Emacs as Pinentry, you might
- come across a Pinentry called @command{pinentry-emacs} or
- @command{gpg-agent} option @code{allow-emacs-pinentry}. However,
---- a/lisp/epg.el
-+++ b/lisp/epg.el
-@@ -595,7 +595,12 @@ epg--start
- (if (epg-context-textmode context) '("--textmode"))
- (if (epg-context-output-file context)
- (list "--output" (epg-context-output-file context)))
-- (if (epg-context-pinentry-mode context)
-+ (if (and (epg-context-pinentry-mode context)
-+ (not
-+ ;; loopback doesn't work with gpgsm
-+ (and (eq (epg-context-protocol context) 'CMS)
-+ (eq (epg-context-pinentry-mode context)
-+ 'loopback))))
- (list "--pinentry-mode"
- (symbol-name (epg-context-pinentry-mode
- context))))
diff --git a/emacs/29.2/03_all_configure-decl.patch b/emacs/29.2/03_all_configure-decl.patch
deleted file mode 100644
index dbee941..0000000
--- a/emacs/29.2/03_all_configure-decl.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-Fix implicit function declaration in configure.ac (XOpenDisplay)
-Backported from master branch
-https://bugs.gentoo.org/898304
-
-commit 6c1413d5ef0d1fea639b0d8c83a0c0065d99359b
-Author: Florian Weimer <fweimer@redhat.com>
-Date: Fri Dec 23 18:49:25 2022 +0100
-
- configure: Remove obsolete check for -b i486-linuxaout
-
---- emacs-29.2/configure.ac
-+++ emacs-29.2/configure.ac
-@@ -2695,39 +2695,6 @@
- export LD_RUN_PATH
- fi
-
-- if test "${opsys}" = "gnu-linux"; then
-- AC_CACHE_CHECK([whether X on GNU/Linux needs -b to link], [emacs_cv_b_link],
-- [AC_LINK_IFELSE([AC_LANG_PROGRAM([[]],
-- [[XOpenDisplay ("foo");]])],
-- [xgnu_linux_first_failure=no],
-- [xgnu_linux_first_failure=yes])
-- if test "${xgnu_linux_first_failure}" = "yes"; then
-- OLD_CPPFLAGS="$CPPFLAGS"
-- OLD_LIBS="$LIBS"
-- CPPFLAGS="$CPPFLAGS -b i486-linuxaout"
-- LIBS="$LIBS -b i486-linuxaout"
-- AC_LINK_IFELSE([AC_LANG_PROGRAM([[]],
-- [[XOpenDisplay ("foo");]])],
-- [xgnu_linux_second_failure=no],
-- [xgnu_linux_second_failure=yes])
-- if test "${xgnu_linux_second_failure}" = "yes"; then
-- # If we get the same failure with -b, there is no use adding -b.
-- # So leave it out. This plays safe.
-- emacs_cv_b_link=no
-- else
-- emacs_cv_b_link=yes
-- fi
-- CPPFLAGS=$OLD_CPPFLAGS
-- LIBS=$OLD_LIBS
-- else
-- emacs_cv_b_link=no
-- fi])
-- if test "x$emacs_cv_b_link" = xyes ; then
-- LD_SWITCH_X_SITE="$LD_SWITCH_X_SITE -b i486-linuxaout"
-- C_SWITCH_X_SITE="$C_SWITCH_X_SITE -b i486-linuxaout"
-- fi
-- fi
--
- # Reportedly, some broken Solaris systems have XKBlib.h but are missing
- # header files included from there.
- AC_CACHE_CHECK([for Xkb], [emacs_cv_xkb],