aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaksim 'max_posedon' Melnikau <maxposedon@gmail.com>2010-10-15 11:20:48 +0300
committerMaksim 'max_posedon' Melnikau <maxposedon@gmail.com>2010-10-15 11:20:48 +0300
commitb7ce262a845a6feb031df77f66496f857f45ab27 (patch)
treeab5e65fecf07eebd1ac63b0ed5055028e00f6986 /app-editors/vim-core/vim-core-7.3.ebuild
parentFix shr.eclass: dev-util/cvs moved to dev-vcs/cvs (diff)
downloadembedded-cross-b7ce262a845a6feb031df77f66496f857f45ab27.tar.gz
embedded-cross-b7ce262a845a6feb031df77f66496f857f45ab27.tar.bz2
embedded-cross-b7ce262a845a6feb031df77f66496f857f45ab27.zip
vim-7.3 crosscompilation fix uint32_t check
http://bugs.gentoo.org/show_bug.cgi?id=333247 Signed-off-by: Maksim 'max_posedon' Melnikau <maxposedon@gmail.com>
Diffstat (limited to 'app-editors/vim-core/vim-core-7.3.ebuild')
-rw-r--r--app-editors/vim-core/vim-core-7.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-editors/vim-core/vim-core-7.3.ebuild b/app-editors/vim-core/vim-core-7.3.ebuild
new file mode 100644
index 0000000..35a9caa
--- /dev/null
+++ b/app-editors/vim-core/vim-core-7.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim-core/vim-core-7.3.ebuild,v 1.2 2010/09/27 21:12:58 redhatter Exp $
+
+EAPI=3
+VIM_VERSION="7.3"
+inherit vim
+
+VIM_CORE_GENTOO_PATCHES="vim-core-${VIM_VERSION}-gentoo-patches.tar.bz2"
+#VIM_ORG_PATCHES="vim-patches-${PV}.tar.gz"
+VIMRC_FILE_SUFFIX="-r4"
+
+SRC_URI="ftp://ftp.vim.org/pub/vim/unix/vim-${VIM_VERSION}.tar.bz2
+ mirror://gentoo/${VIM_CORE_GENTOO_PATCHES}"
+
+# New release... no patches yet
+# mirror://gentoo/${VIM_ORG_PATCHES}"
+
+S="${WORKDIR}/vim${VIM_VERSION/.}"
+DESCRIPTION="vim and gvim shared files"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-cross-uint32.patch
+ vim_src_prepare
+}