aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Piasek <dagger@gentoo.org>2009-01-09 16:17:04 +0000
committerRobert Piasek <dagger@gentoo.org>2009-01-09 16:17:04 +0000
commit6148701714b9d10fc51cf9eb503673f84b767bc0 (patch)
tree66518c473a10185bae8de12afa08601d144b158a /sys-apps/file
parentTesing svn access (diff)
downloadembedded-cross-6148701714b9d10fc51cf9eb503673f84b767bc0.tar.gz
embedded-cross-6148701714b9d10fc51cf9eb503673f84b767bc0.tar.bz2
embedded-cross-6148701714b9d10fc51cf9eb503673f84b767bc0.zip
Initial upload of openmoko-target
Diffstat (limited to 'sys-apps/file')
-rw-r--r--sys-apps/file/Manifest5
-rw-r--r--sys-apps/file/file-4.23.ebuild63
-rw-r--r--sys-apps/file/file-4.26.ebuild63
-rw-r--r--sys-apps/file/files/file-4.15-libtool.patch19
4 files changed, 150 insertions, 0 deletions
diff --git a/sys-apps/file/Manifest b/sys-apps/file/Manifest
new file mode 100644
index 0000000..94ad143
--- /dev/null
+++ b/sys-apps/file/Manifest
@@ -0,0 +1,5 @@
+AUX file-4.15-libtool.patch 561 RMD160 f2b9f4c93f199ab3145d70816b3c624349af97a0 SHA1 6e2c1cd8dee4d022c35a056e94a4030af1f4b1fa SHA256 badb8261dad5df39bac1d6a6da1668eb8a2ff0b01c2c80baa8abfe07fd99681d
+DIST file-4.23.tar.gz 563704 RMD160 29153a3fb18b2d8f7da9fd66712fbd6ed4ea49f2 SHA1 83a90894a6b89f80207b9fcf0e382a627e4c5f0b SHA256 2fad96e6475b7a67e1e96f05e825b779686fd0cb3f041a10ca6622a4d9f7d147
+DIST file-4.26.tar.gz 584803 RMD160 e8b84e01d1f43faedfe676afc92c2cba4a01ecdf SHA1 412cdac5cd778d867e2d91a01b09858be1998ec3 SHA256 682f7de5c12d35ff2d9e2ec3c6a753bd5a01e0f7f3110501be0bafef1d5e9654
+EBUILD file-4.23.ebuild 1632 RMD160 bca597f4035cbcdc92d707de8258e97a6f71eeaf SHA1 58a610bd9a2966ba1d226817c47c25578d072e89 SHA256 74e34681d73def1c21d1f5eb45e18ad94d204d77f214ff901b0db545f27aef1e
+EBUILD file-4.26.ebuild 1644 RMD160 1e1a7937d7f8202bd22a28b73067bbdfcbe0e7cd SHA1 a9b6dd753516f464fbdd9bf9dd21952305418fd9 SHA256 6fea044db910aa0ad44bf428567a04d6a8dd1a8f5207434e5773ead99ad2dcd8
diff --git a/sys-apps/file/file-4.23.ebuild b/sys-apps/file/file-4.23.ebuild
new file mode 100644
index 0000000..a028404
--- /dev/null
+++ b/sys-apps/file/file-4.23.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.23.ebuild,v 1.7 2008/03/29 15:23:34 ranger Exp $
+
+inherit eutils distutils libtool flag-o-matic toolchain-funcs
+
+DESCRIPTION="identify a file's format by scanning binary data for patterns"
+HOMEPAGE="ftp://ftp.astron.com/pub/file/"
+SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.gz
+ ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
+IUSE="python"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-4.15-libtool.patch #99593
+
+ elibtoolize
+ epunt_cxx
+
+ # make sure python links against the current libmagic #54401
+ sed -i "/library_dirs/s:'\.\./src':'../src/.libs':" python/setup.py
+
+ if tc-is-cross-compiler ; then
+ # make sure cross-compilation uses correct libs and headers
+ sed -i -e "s%'/usr/%'${SYSROOT}/usr/%g" python/setup.py
+ fi
+
+ # dont let python README kill main README #60043
+ mv python/README{,.python}
+}
+
+src_compile() {
+ # file uses things like strndup() and wcwidth()
+ append-flags -D_GNU_SOURCE
+
+ econf --datadir=/usr/share/misc || die
+ emake || die "emake failed"
+
+ use python && cd python && distutils_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog MAINT README
+
+ use python && cd python && distutils_src_install
+}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}
diff --git a/sys-apps/file/file-4.26.ebuild b/sys-apps/file/file-4.26.ebuild
new file mode 100644
index 0000000..8fe0b37
--- /dev/null
+++ b/sys-apps/file/file-4.26.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/file/file-4.26.ebuild,v 1.1 2008/09/17 09:51:34 vapier Exp $
+
+inherit eutils distutils libtool flag-o-matic toolchain-funcs
+
+DESCRIPTION="identify a file's format by scanning binary data for patterns"
+HOMEPAGE="ftp://ftp.astron.com/pub/file/"
+SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.gz
+ ftp://ftp.gw.com/mirrors/pub/unix/file/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="python"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-4.15-libtool.patch #99593
+
+ elibtoolize
+ epunt_cxx
+
+ # make sure python links against the current libmagic #54401
+ sed -i "/library_dirs/s:'\.\./src':'../src/.libs':" python/setup.py
+
+ if tc-is-cross-compiler ; then
+ # make sure cross-compilation uses correct libs and headers
+ sed -i -e "s%'/usr/%'${SYSROOT}/usr/%g" python/setup.py
+ fi
+
+ # dont let python README kill main README #60043
+ mv python/README{,.python}
+}
+
+src_compile() {
+ # file uses things like strndup() and wcwidth()
+ append-flags -D_GNU_SOURCE
+
+ econf --datadir=/usr/share/misc || die
+ emake || die "emake failed"
+
+ use python && cd python && distutils_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog MAINT README
+
+ use python && cd python && distutils_src_install
+}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}
diff --git a/sys-apps/file/files/file-4.15-libtool.patch b/sys-apps/file/files/file-4.15-libtool.patch
new file mode 100644
index 0000000..c41c8fe
--- /dev/null
+++ b/sys-apps/file/files/file-4.15-libtool.patch
@@ -0,0 +1,19 @@
+Fix build time issues with tools who like to export LD_LIBRARY_PATH
+to retarded values.
+
+http://bugs.gentoo.org/99593
+
+--- ltmain.sh
++++ ltmain.sh
+@@ -5085,6 +5085,11 @@
+ $echo >> $output "\
+ if test \"\$libtool_execute_magic\" != \"$magic\"; then
+ # Run the actual program with our arguments.
++
++ # Make sure env LD_LIBRARY_PATH does not mess us up
++ if test -n \"\${LD_LIBRARY_PATH+set}\"; then
++ export LD_LIBRARY_PATH=\$progdir:\$LD_LIBRARY_PATH
++ fi
+ "
+ case $host in
+ # Backslashes separate directories on plain windows