aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Piasek <dagger@gentoo.org>2009-02-06 22:59:09 +0000
committerRobert Piasek <dagger@gentoo.org>2009-02-06 22:59:09 +0000
commita367b9ac9bf1cf9a064e14bda08355c596f90841 (patch)
tree4feff99ad302a7d1e6e11a9404a5b104cd69b15e /sys-mobilephone/fso-abyss
parentNew ebuild for libgee (diff)
downloadembedded-cross-a367b9ac9bf1cf9a064e14bda08355c596f90841.tar.gz
embedded-cross-a367b9ac9bf1cf9a064e14bda08355c596f90841.tar.bz2
embedded-cross-a367b9ac9bf1cf9a064e14bda08355c596f90841.zip
New ebuild for EXPERIMENTAL gsm muxer
IT DOESN'T WORK YET. Purely for testing and debuging purposes.
Diffstat (limited to 'sys-mobilephone/fso-abyss')
-rw-r--r--sys-mobilephone/fso-abyss/Manifest1
-rw-r--r--sys-mobilephone/fso-abyss/fso-abyss-0.2.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/sys-mobilephone/fso-abyss/Manifest b/sys-mobilephone/fso-abyss/Manifest
new file mode 100644
index 0000000..e769582
--- /dev/null
+++ b/sys-mobilephone/fso-abyss/Manifest
@@ -0,0 +1 @@
+EBUILD fso-abyss-0.2.0.ebuild 827 RMD160 0cb92a392bee043c159379e0e762d5af9daa17a0 SHA1 fa18e00ed5e75443d10f0417651de02bafe412c6 SHA256 c4c3b5f79cd11d80c67a3e3279bdd28aba77ab7c579dd5e232ca76b356c4517d
diff --git a/sys-mobilephone/fso-abyss/fso-abyss-0.2.0.ebuild b/sys-mobilephone/fso-abyss/fso-abyss-0.2.0.ebuild
new file mode 100644
index 0000000..8e5d18b
--- /dev/null
+++ b/sys-mobilephone/fso-abyss/fso-abyss-0.2.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit autotools git
+
+DESCRIPTION="The FreeSmartPhone.org GSM multiplexer"
+HOMEPAGE="http://www.freesmartphone.org"
+EGIT_REPO_URI="git://git.freesmartphone.org/fso-abyss.git"
+EGIT_TREE="tags/0.2.0"
+EGIT_PROJECT="fso-abbys.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~arm"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.0
+ >=dev-libs/dbus-glib-0.76
+ >=dev-libs/libgee-0.1"
+DEPEND="${RDEPEND}
+ dev-lang/vala"
+
+
+src_unpack() {
+ # Fetch and unpack current git sources
+ git_src_unpack
+
+ cd "${S}"
+
+ eautoreconf || die "eautoreconf failed"
+}
+
+src_compile() {
+
+ econf || dir "econf failed"
+ emake || die "emake died"
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" install || die "make install failed"
+}