aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven 'sleipnir' Rebhan <odinshorse@googlemail.com>2009-06-16 19:10:37 +0000
committerSven 'sleipnir' Rebhan <odinshorse@googlemail.com>2009-06-16 19:10:37 +0000
commiteb8cf2681403ef9cd9fe11e70719e5d4cc85160a (patch)
treeafe104e1e750eb4c9f9dc7fbd98d2ca16813b1b1 /x11-apps
parentApply patch found on miranda. Please report these patches to http://gentoo.mi... (diff)
downloadembedded-cross-eb8cf2681403ef9cd9fe11e70719e5d4cc85160a.tar.gz
embedded-cross-eb8cf2681403ef9cd9fe11e70719e5d4cc85160a.tar.bz2
embedded-cross-eb8cf2681403ef9cd9fe11e70719e5d4cc85160a.zip
Xinerama is not mandatory for xdm!
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xdm/Manifest6
-rwxr-xr-xx11-apps/xdm/files/Xsession73
-rw-r--r--x11-apps/xdm/files/wtmp.patch18
-rw-r--r--x11-apps/xdm/files/xdm.pamd6
-rw-r--r--x11-apps/xdm/files/xwilling-hang.patch11
-rw-r--r--x11-apps/xdm/xdm-1.1.8.ebuild55
6 files changed, 169 insertions, 0 deletions
diff --git a/x11-apps/xdm/Manifest b/x11-apps/xdm/Manifest
new file mode 100644
index 0000000..d41086e
--- /dev/null
+++ b/x11-apps/xdm/Manifest
@@ -0,0 +1,6 @@
+AUX Xsession 1521 RMD160 c02efb9e96a8dc836d71aa1b47c36358ad61129c SHA1 b94699037a667c716462296c25b4d912fd5d783b SHA256 8a09cd1cef9ebce190e13009e8b21a8504eac1cec3fc31a10d3740b6c7aa49b6
+AUX wtmp.patch 799 RMD160 515f6fb67c43877c41384a5012a9afea047b6f22 SHA1 2591d85c31703f46b643894515823c47a707151b SHA256 7ce7c837484e380be21022ffa4e306ee8c555fbffd6e53e85aef59f24074020d
+AUX xdm.pamd 169 RMD160 3966ca34d9600db06be7e672b66b0ae23c8e9282 SHA1 48e97b23aefa2ed4bacd4b8bd0b9bed424faead7 SHA256 5e334101825dba22adacefc3becc9294e6ff7e6834b6d58f228fec9b0df8259b
+AUX xwilling-hang.patch 589 RMD160 1c624acd002d4b45cf6fb318ab4010425120c09b SHA1 df9d176961a1a84da2ee94667fb601634268c923 SHA256 7ee42e52cf2e2aedba74daabee0bb2fa4648262eb00dc92bc778c61b9afb59f4
+DIST xdm-1.1.8.tar.bz2 401712 RMD160 5435ff73a8fea36ecb071462121308f828d47927 SHA1 619d810d9cd60e193be72365791cdb4057fc56ce SHA256 e1169058775a44b0898351d2f645039b4d8946360285831e553587a147b735e9
+EBUILD xdm-1.1.8.ebuild 1304 RMD160 f3d6e246b6f6ba97f86089dcc871c2a33de4fc6d SHA1 313280ed9f5dd3af8e9d38c8cd2f840b1bc3d92a SHA256 2bbb3a2af8fec5ca9479c2780c7946347715eb48c47daa1b8cd85e535f0919bd
diff --git a/x11-apps/xdm/files/Xsession b/x11-apps/xdm/files/Xsession
new file mode 100755
index 0000000..ffeef4c
--- /dev/null
+++ b/x11-apps/xdm/files/Xsession
@@ -0,0 +1,73 @@
+#!/bin/bash --login
+#
+# $Xorg: Xsession,v 1.4 2000/08/17 19:54:17 cpqbld Exp $
+#
+#
+#
+#
+# $XFree86: xc/programs/xdm/config/Xsession,v 1.3 2001/01/17 23:45:24 dawes Exp $
+
+# redirect errors to a file in user's home directory if we can
+for errfile in "$HOME/.xsession-errors" "${TMPDIR-/tmp}/xses-$USER" "/tmp/xses-$USER"
+do
+ if ( cp /dev/null "$errfile" 2> /dev/null )
+ then
+ chmod 600 "$errfile"
+ exec > "$errfile" 2>&1
+ break
+ fi
+done
+
+# handle KDM
+if [ -n "$1" ]; then
+ export XSESSION="$1"
+fi
+
+xinitdir=/usr/X11R6/lib/X11/xinit
+startup=$HOME/.xsession
+userresources=$HOME/.Xresources
+usermodmap=$HOME/.Xmodmap
+sysresources=$xinitdir/.Xresources
+sysmodmap=$xinitdir/.Xmodmap
+
+# First run the system default. Because KDE uses this
+# to switch sessions, we MUST first check the system
+# default, and then ~/.xsession. If the user Do not
+# want this, he should override XSESSION, or at least
+# clear it.
+if [ -n "`/etc/X11/chooser.sh`" ]; then
+ exec "`/etc/X11/chooser.sh`"
+# If not defined, try the user's ~/.xsession
+elif [ -s "$startup" ]; then
+
+ # merge in defaults and keymaps
+
+ if [ -f $sysresources ]; then
+ xrdb -merge $sysresources
+ fi
+
+ if [ -f $sysmodmap ]; then
+ xmodmap $sysmodmap
+ fi
+
+ if [ -f $userresources ]; then
+ xrdb -merge $userresources
+ fi
+
+ if [ -f $usermodmap ]; then
+ xmodmap $usermodmap
+ fi
+
+ if [ -x "$startup" ]; then
+ exec "$startup"
+ else
+ exec /bin/sh "$startup"
+ fi
+# Lastly, xsm as failsafe
+else
+ if [ -r "$userresources" ]; then
+ xrdb -load "$userresources"
+ fi
+ exec xsm
+fi
+
diff --git a/x11-apps/xdm/files/wtmp.patch b/x11-apps/xdm/files/wtmp.patch
new file mode 100644
index 0000000..6d2d0a9
--- /dev/null
+++ b/x11-apps/xdm/files/wtmp.patch
@@ -0,0 +1,18 @@
+diff -urN xdm-1.0.3.orig/config/GiveConsole xdm-1.0.3/config/GiveConsole
+--- xdm-1.0.3.orig/config/GiveConsole 2006-04-19 22:40:45.000000000 -0700
++++ xdm-1.0.3/config/GiveConsole 2006-04-19 23:06:51.000000000 -0700
+@@ -8,3 +8,5 @@
+ # causing serious grief.
+ #
+ chown $USER /dev/console
++/usr/bin/sessreg -a -w "/var/log/wtmp" -u "/var/run/utmp" \
++ -x "/etc/X11/xdm/Xservers" -l $DISPLAY -h "" $USER
+diff -urN xdm-1.0.3.orig/config/TakeConsole xdm-1.0.3/config/TakeConsole
+--- xdm-1.0.3.orig/config/TakeConsole 2006-04-19 22:40:45.000000000 -0700
++++ xdm-1.0.3/config/TakeConsole 2006-04-19 23:07:37.000000000 -0700
+@@ -5,3 +5,5 @@
+ #
+ chmod 622 /dev/console
+ chown root /dev/console
++/usr/bin/sessreg -d -w "/var/log/wtmp" -u "/var/run/utmp" \
++ -x "/etc/X11/xdm/Xservers" -l $DISPLAY -h "" $USER
diff --git a/x11-apps/xdm/files/xdm.pamd b/x11-apps/xdm/files/xdm.pamd
new file mode 100644
index 0000000..4ab9695
--- /dev/null
+++ b/x11-apps/xdm/files/xdm.pamd
@@ -0,0 +1,6 @@
+#%PAM-1.0
+auth required pam_nologin.so
+auth include system-auth
+account include system-auth
+password include system-auth
+session include system-auth
diff --git a/x11-apps/xdm/files/xwilling-hang.patch b/x11-apps/xdm/files/xwilling-hang.patch
new file mode 100644
index 0000000..93a0b14
--- /dev/null
+++ b/x11-apps/xdm/files/xwilling-hang.patch
@@ -0,0 +1,11 @@
+--- xdm-1.0.3.orig/config/xdm-config.cpp 2006-04-19 22:40:45.000000000 -0700
++++ xdm-1.0.3/config/xdm-config.cpp 2006-04-19 23:10:44.000000000 -0700
+@@ -18,7 +18,7 @@
+ DisplayManager.servers: XDMCONFIGDIR/Xservers
+ DisplayManager.accessFile: XDMCONFIGDIR/Xaccess
+ DisplayManager*resources: XDMCONFIGDIR/Xresources
+-DisplayManager.willing: SU nobody -c XDMSCRIPTDIR/Xwilling
++DisplayManager.willing: XDMSCRIPTDIR/Xwilling
+ ! All displays should use authorization, but we cannot be sure
+ ! X terminals may not be configured that way, so they will require
+ ! individual resource settings.
diff --git a/x11-apps/xdm/xdm-1.1.8.ebuild b/x11-apps/xdm/xdm-1.1.8.ebuild
new file mode 100644
index 0000000..01137e3
--- /dev/null
+++ b/x11-apps/xdm/xdm-1.1.8.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/xdm-1.1.8.ebuild,v 1.10 2009/05/05 08:32:09 fauli Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit multilib x-modular pam
+
+DEFAULTVT="vt7"
+
+DESCRIPTION="X.Org xdm application"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+IUSE="ipv6 pam xinerama"
+
+RDEPEND="x11-apps/xrdb
+ x11-libs/libXdmcp
+ x11-libs/libXaw
+ >=x11-apps/xinit-1.0.2-r3
+ xinerama? ( x11-libs/libXinerama )
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-apps/sessreg"
+DEPEND="${RDEPEND}
+ xinerama? ( x11-proto/xineramaproto )
+ x11-proto/xproto"
+
+PATCHES=( "${FILESDIR}"/wtmp.patch
+ "${FILESDIR}"/xwilling-hang.patch )
+
+pkg_setup() {
+ CONFIGURE_OPTIONS="$(use_enable ipv6)
+ $(use_with pam)
+ --disable-xprint
+ --with-default-vt=${DEFAULTVT}
+ --with-xdmconfigdir=/etc/X11/xdm"
+}
+
+src_install() {
+ x-modular_src_install
+ exeinto /usr/$(get_libdir)/X11/xdm
+ doexe "${FILESDIR}"/Xsession
+ newpamd "${FILESDIR}"/xdm.pamd xdm
+}
+
+pkg_preinst() {
+ x-modular_pkg_preinst
+
+ # Check for leftover /usr/lib/X11/xdm symlink
+ if [[ -L "/usr/lib/X11/xdm" ]]; then
+ ewarn "/usr/lib/X11/xdm is a symlink; deleting."
+ rm /usr/lib/X11/xdm
+ fi
+}