aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/vala/vala-0.7.10.1.ebuild')
-rw-r--r--dev-lang/vala/vala-0.7.10.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-lang/vala/vala-0.7.10.1.ebuild b/dev-lang/vala/vala-0.7.10.1.ebuild
new file mode 100644
index 0000000..bc42fb0
--- /dev/null
+++ b/dev-lang/vala/vala-0.7.10.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/vala/vala-0.7.7.ebuild,v 1.1 2009/10/17 10:40:54 mrpouet Exp $
+
+EAPI=1
+GCONF_DEBUG=no
+inherit gnome2
+
+DESCRIPTION="Vala - Compiler for the GObject type system"
+HOMEPAGE="http://live.gnome.org/Vala"
+SRC_URI="http://www.freesmartphone.org/sources/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="test +vapigen +coverage"
+
+#FIXME: flex and bison are in "base" profile,
+# so why put them into DEPEND ?
+RDEPEND=">=dev-libs/glib-2.12"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ || ( sys-devel/bison dev-util/byacc dev-util/yacc )
+ dev-util/pkgconfig
+ dev-libs/libxslt
+ test? ( dev-libs/dbus-glib )"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable vapigen)
+ $(use_enable coverage)"
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+}