aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xf86-video-glamo/xf86-video-glamo-9999.ebuild')
-rw-r--r--x11-drivers/xf86-video-glamo/xf86-video-glamo-9999.ebuild20
1 files changed, 18 insertions, 2 deletions
diff --git a/x11-drivers/xf86-video-glamo/xf86-video-glamo-9999.ebuild b/x11-drivers/xf86-video-glamo/xf86-video-glamo-9999.ebuild
index 7c8cede..6e93c7a 100644
--- a/x11-drivers/xf86-video-glamo/xf86-video-glamo-9999.ebuild
+++ b/x11-drivers/xf86-video-glamo/xf86-video-glamo-9999.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+EAPI=2
XDPVER=-1
inherit x-modular git
@@ -14,7 +15,7 @@ EGIT_PROJECT="xf86-video-glamo"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~arm"
-IUSE="dri"
+IUSE="dri kms"
use dri && EGIT_BRANCH="kms"
@@ -25,7 +26,14 @@ DEPEND="${RDEPEND}
x11-proto/renderproto
x11-proto/xextproto
x11-proto/xproto
- x11-proto/videoproto"
+ x11-proto/videoproto
+ x11-libs/libdrm[video_cards_glamo]"
+
+pkg_setup() {
+ if use kms ; then
+ ewarn "If you experience build or run time difficulties, try disabling kms use flag."
+ fi
+}
src_unpack() {
git_src_unpack
@@ -35,6 +43,14 @@ src_unpack() {
eautoreconf || die "eautoreconf failed"
}
+src_compile() {
+ local myconf
+ myconf="${myconf} --disable-kms"
+ use kms && myconf="${myconf} --enable-kms"
+
+ econf ${myconf} || die "Configuration failed"
+ emake || die "Make failed"
+}
src_install() {
x-modular_src_install