summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2011-07-09 17:33:11 +0000
committerThomas Sachau <tommy@gentoo.org>2011-07-09 17:33:11 +0000
commitd989430212311a5aed6135acf6a798e62481f082 (patch)
tree40815bd8b71975cd93e24f39c428cc410fc9840f /media-libs
parentRemove unused configure options, disable ecore-evas-software-x11, since the r... (diff)
downloadenlightenment-d989430212311a5aed6135acf6a798e62481f082.tar.gz
enlightenment-d989430212311a5aed6135acf6a798e62481f082.tar.bz2
enlightenment-d989430212311a5aed6135acf6a798e62481f082.zip
Remove the static part, avoids compile failure for ecore with --enable-ecore-evas-software-x11, thanks to the_mgt for catching this issue
(Portage version: 2.2.0_alpha43-r1/svn/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/evas/ChangeLog6
-rw-r--r--media-libs/evas/evas-9999.ebuild42
2 files changed, 26 insertions, 22 deletions
diff --git a/media-libs/evas/ChangeLog b/media-libs/evas/ChangeLog
index 0566178..13ced33 100644
--- a/media-libs/evas/ChangeLog
+++ b/media-libs/evas/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for media-libs/evas
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
# $Header: $
+ 09 Jul 2011; Thomas Sachau (Tommy[D]) <tommy@gentoo.org> evas-9999.ebuild:
+ Remove the static part, avoids compile failure for ecore with
+ --enable-ecore-evas-software-x11, thanks to the_mgt for catching this issue
+
17 Dec 2010; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
-evas-1.0.0_beta.ebuild:
Drop old
diff --git a/media-libs/evas/evas-9999.ebuild b/media-libs/evas/evas-9999.ebuild
index 3436b8b..a7423f6 100644
--- a/media-libs/evas/evas-9999.ebuild
+++ b/media-libs/evas/evas-9999.ebuild
@@ -57,8 +57,8 @@ src_configure() {
use opengl && ewarn "opengl support is not implemented with xcb"
MY_ECONF="
--disable-gl-x11
- --enable-software-xcb=static
- --enable-xrender-xcb=static
+ --enable-software-xcb
+ --enable-xrender-xcb
"
else
MY_ECONF="
@@ -71,39 +71,39 @@ src_configure() {
MY_ECONF+="
$(use_enable altivec cpu-altivec)
$(use_enable bidi fribidi)
- $(use_enable bmp image-loader-bmp static)
- $(use_enable bmp image-loader-wbmp static)
+ $(use_enable bmp image-loader-bmp)
+ $(use_enable bmp image-loader-wbmp)
$(use_enable cache metric-cache)
$(use_enable cache word-cache)
- $(use_enable directfb static)
+ $(use_enable directfb)
$(use_enable doc)
- $(use_enable eet font-loader-eet static)
- $(use_enable eet image-loader-eet static)
- $(use_enable fbcon fb static)
+ $(use_enable eet font-loader-eet)
+ $(use_enable eet image-loader-eet)
+ $(use_enable fbcon fb)
$(use_enable fontconfig)
$(use_enable gles gl-flavor-gles)
$(use_enable gles gles-variety-sgx)
- $(use_enable gif image-loader-gif static)
- $(use_enable ico image-loader-ico static)
- $(use_enable jpeg image-loader-jpeg static)
+ $(use_enable gif image-loader-gif)
+ $(use_enable ico image-loader-ico)
+ $(use_enable jpeg image-loader-jpeg)
$(use_enable mmx cpu-mmx)
- $(use_enable png image-loader-png static)
- $(use_enable ppm image-loader-pmaps static)
- $(use_enable sdl software-sdl static)
+ $(use_enable png image-loader-png)
+ $(use_enable ppm image-loader-pmaps)
+ $(use_enable sdl software-sdl)
$(use_enable sse cpu-sse)
- $(use_enable svg image-loader-svg static)
- $(use_enable tga image-loader-tga static)
- $(use_enable tiff image-loader-tiff static)
+ $(use_enable svg image-loader-svg)
+ $(use_enable tga image-loader-tga)
+ $(use_enable tiff image-loader-tiff)
$(use_enable threads pthreads)
$(use_enable threads async-events)
$(use_enable threads async-preload)
$(use_enable threads async-render)
- $(use_enable X software-xlib static)
- $(use_enable X xrender-x11 static)
- $(use_enable xpm image-loader-xpm static)
+ $(use_enable X software-xlib)
+ $(use_enable X xrender-x11)
+ $(use_enable xpm image-loader-xpm)
--enable-evas-magic-debug \
--enable-static-software-generic \
- --enable-buffer=static \
+ --enable-buffer \
--enable-cpu-c \
--enable-scale-sample \
--enable-scale-smooth \