aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael G. Martins <rafael@rafaelmartins.eng.br>2010-08-04 00:57:44 -0300
committerRafael G. Martins <rafael@rafaelmartins.eng.br>2010-08-04 00:57:44 -0300
commitae014ea351f608088c0cc88b0f03e7ac10c8bf74 (patch)
treecf7b3bde1d1da65d2c012afa85a2ec11fb90b676
parentupdated setup.py (diff)
downloadg-octave-ae014ea351f608088c0cc88b0f03e7ac10c8bf74.tar.gz
g-octave-ae014ea351f608088c0cc88b0f03e7ac10c8bf74.tar.bz2
g-octave-ae014ea351f608088c0cc88b0f03e7ac10c8bf74.zip
fixed the cleanup of package database before extract the new
-rw-r--r--g_octave/__init__.py2
-rw-r--r--g_octave/fetch.py2
2 files changed, 2 insertions, 2 deletions
diff --git a/g_octave/__init__.py b/g_octave/__init__.py
index 2ea55bd..d17e8c8 100644
--- a/g_octave/__init__.py
+++ b/g_octave/__init__.py
@@ -32,4 +32,4 @@ __url__ = 'http://g-octave.rafaelmartins.eng.br/'
__copyright__ = '(c) 2009-2010 %s' % __author__
__license__ = 'GPLv2'
-__version__ = '0.3'
+__version__ = '0.4'
diff --git a/g_octave/fetch.py b/g_octave/fetch.py
index 5751ca0..b8a8d6c 100644
--- a/g_octave/fetch.py
+++ b/g_octave/fetch.py
@@ -40,7 +40,7 @@ import tarfile
from contextlib import closing
def clean_db():
- for f in ['info.json', 'patches', 'octave-forge']:
+ for f in ['timestamp', 'info.json', 'patches', 'octave-forge']:
current = os.path.join(conf.db, f)
if os.path.isdir(current):
shutil.rmtree(current)