summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-03-04 02:00:44 +0300
committerAzamat H. Hackimov <azamat.hackimov@gmail.com>2020-03-04 02:00:44 +0300
commitb9e7e3755e2c6faf6a583bc51c02f7302ed3b027 (patch)
treea87004629bf40ba4d4058bfbc539950deacfe67c /games-strategy
parentgames-strategy/revenge-of-the-titans: update package (diff)
downloadgamerlay-b9e7e3755e2c6faf6a583bc51c02f7302ed3b027.tar.gz
gamerlay-b9e7e3755e2c6faf6a583bc51c02f7302ed3b027.tar.bz2
gamerlay-b9e7e3755e2c6faf6a583bc51c02f7302ed3b027.zip
games-strategy/uplink: update package
Migrate from deprecated eclass. Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/uplink/metadata.xml4
-rw-r--r--games-strategy/uplink/uplink-1.6-r1.ebuild (renamed from games-strategy/uplink/uplink-1.6.ebuild)21
2 files changed, 15 insertions, 10 deletions
diff --git a/games-strategy/uplink/metadata.xml b/games-strategy/uplink/metadata.xml
new file mode 100644
index 0000000..097975e
--- /dev/null
+++ b/games-strategy/uplink/metadata.xml
@@ -0,0 +1,4 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+</pkgmetadata>
diff --git a/games-strategy/uplink/uplink-1.6.ebuild b/games-strategy/uplink/uplink-1.6-r1.ebuild
index 66309f2..c8c2be7 100644
--- a/games-strategy/uplink/uplink-1.6.ebuild
+++ b/games-strategy/uplink/uplink-1.6-r1.ebuild
@@ -1,6 +1,9 @@
-EAPI=5
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
-inherit games
+EAPI=7
+
+inherit desktop eutils
MY_P="${PN}_${PV}-1"
@@ -11,11 +14,11 @@ SRC_URI="amd64? ( ${MY_P}_amd64.tar.gz )
RESTRICT="fetch"
# Bundled libs :(
-QA_PRESTRIPPED="${GAMES_PREFIX_OPT}/${PN}/lib.*"
+QA_PRESTRIPPED="/opt/${PN}/lib.*"
-LICENSE="introversion"
+LICENSE="all-rights-reserved"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="-* ~amd64 ~x86"
IUSE=""
DEPEND=""
@@ -33,7 +36,7 @@ pkg_nofetch() {
src_unpack() {
local root
- unpack "${A}"
+ unpack ${A}
if use amd64; then
root=uplink-x64
@@ -49,7 +52,7 @@ src_unpack() {
S="${WORKDIR}/${PN}"
src_install() {
- local dir="${GAMES_PREFIX_OPT}/${PN}"
+ local dir="/opt/${PN}"
local exe lib
insinto "${dir}"
@@ -77,9 +80,7 @@ src_install() {
doicon uplink.png
make_desktop_entry "${PN}" Uplink uplink
- games_make_wrapper "${PN}" "${dir}/$exe"
+ make_wrapper "${PN}" "${dir}/$exe"
dodoc changes.txt mods.txt readme.txt
-
- prepgamesdirs
}