aboutsummaryrefslogtreecommitdiff
path: root/8.2.0
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-10-20 10:28:23 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-10-20 10:28:23 +0100
commitb016826c93875380dc8f570a54bc3652de2fc79e (patch)
treea1ab0b1bf0c62ada777298bc4789c2f6a84cdda0 /8.2.0
parent4.9.4: drop assumed -lieee from -mieee-fp (diff)
downloadgcc-patches-b016826c93875380dc8f570a54bc3652de2fc79e.tar.gz
gcc-patches-b016826c93875380dc8f570a54bc3652de2fc79e.tar.bz2
gcc-patches-b016826c93875380dc8f570a54bc3652de2fc79e.zip
8.2.0: drop libstdc++ libking against libvtv
libstdc++ itself provides weak symbols to work both against present and missing libvtv. Final binary desides whetned to use vtv or not by linking against libvtv. The change drops libvtv RPATH=${build_dir} injection. Bug: https://bugs.gentoo.org/582524 Bug: https://gcc.gnu.org/PR85884 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to '8.2.0')
-rw-r--r--8.2.0/gentoo/112_all_libstdcxx-no-vtv.patch61
-rw-r--r--8.2.0/gentoo/README.history1
2 files changed, 62 insertions, 0 deletions
diff --git a/8.2.0/gentoo/112_all_libstdcxx-no-vtv.patch b/8.2.0/gentoo/112_all_libstdcxx-no-vtv.patch
new file mode 100644
index 0000000..68508bd
--- /dev/null
+++ b/8.2.0/gentoo/112_all_libstdcxx-no-vtv.patch
@@ -0,0 +1,61 @@
+Final libstdc++.so should not contain rpath to make libvtv usable.
+It's up to final binaries to link against proper libvtv.
+
+Bug: https://bugs.gentoo.org/582524
+Bug: https://gcc.gnu.org/PR85884
+--- a/libstdc++-v3/src/Makefile.am
++++ b/libstdc++-v3/src/Makefile.am
+@@ -217,7 +217,6 @@ CXXLINK = \
+ $(LIBTOOL) --tag CXX \
+ $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
+ --mode=link $(CXX) \
+- $(VTV_CXXLINKFLAGS) \
+ $(OPT_LDFLAGS) $(SECTION_LDFLAGS) $(AM_CXXFLAGS) $(LTLDFLAGS) -o $@
+
+ # Symbol versioning for shared libraries.
+--- a/libstdc++-v3/src/Makefile.in
++++ b/libstdc++-v3/src/Makefile.in
+@@ -511,7 +511,6 @@ CXXLINK = \
+ $(LIBTOOL) --tag CXX \
+ $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
+ --mode=link $(CXX) \
+- $(VTV_CXXLINKFLAGS) \
+ $(OPT_LDFLAGS) $(SECTION_LDFLAGS) $(AM_CXXFLAGS) $(LTLDFLAGS) -o $@
+
+ @ENABLE_SYMVERS_TRUE@CLEANFILES = libstdc++-symbols.ver $(version_dep)
+--- a/libstdc++-v3/src/c++11/Makefile.am
++++ b/libstdc++-v3/src/c++11/Makefile.am
+@@ -204,5 +204,4 @@ CXXLINK = \
+ $(LIBTOOL) --tag CXX --tag disable-shared \
+ $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
+ --mode=link $(CXX) \
+- $(VTV_CXXLINKFLAGS) \
+ $(OPT_LDFLAGS) $(SECTION_LDFLAGS) $(AM_CXXFLAGS) $(LTLDFLAGS) -o $@
+--- a/libstdc++-v3/src/c++11/Makefile.in
++++ b/libstdc++-v3/src/c++11/Makefile.in
+@@ -496,7 +496,6 @@ CXXLINK = \
+ $(LIBTOOL) --tag CXX --tag disable-shared \
+ $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
+ --mode=link $(CXX) \
+- $(VTV_CXXLINKFLAGS) \
+ $(OPT_LDFLAGS) $(SECTION_LDFLAGS) $(AM_CXXFLAGS) $(LTLDFLAGS) -o $@
+
+ all: all-am
+--- a/libstdc++-v3/src/c++98/Makefile.am
++++ b/libstdc++-v3/src/c++98/Makefile.am
+@@ -273,5 +273,4 @@ CXXLINK = \
+ $(LIBTOOL) --tag CXX --tag disable-shared \
+ $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
+ --mode=link $(CXX) \
+- $(VTV_CXXLINKFLAGS) \
+ $(OPT_LDFLAGS) $(SECTION_LDFLAGS) $(AM_CXXFLAGS) $(LTLDFLAGS) -o $@
+--- a/libstdc++-v3/src/c++98/Makefile.in
++++ b/libstdc++-v3/src/c++98/Makefile.in
+@@ -500,7 +500,6 @@ CXXLINK = \
+ $(LIBTOOL) --tag CXX --tag disable-shared \
+ $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
+ --mode=link $(CXX) \
+- $(VTV_CXXLINKFLAGS) \
+ $(OPT_LDFLAGS) $(SECTION_LDFLAGS) $(AM_CXXFLAGS) $(LTLDFLAGS) -o $@
+
+ all: all-am
diff --git a/8.2.0/gentoo/README.history b/8.2.0/gentoo/README.history
index 3a021b7..c046242 100644
--- a/8.2.0/gentoo/README.history
+++ b/8.2.0/gentoo/README.history
@@ -1,6 +1,7 @@
1.5 TODO
+ 111_all_ubd-hog-PR85704.patch
U 105_all_libgfortran-Werror.patch
+ + 112_all_libstdcxx-no-vtv.patch
1.4 01 Oct 2018
+ 105_all_libgfortran-Werror.patch