summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-03-16 00:06:27 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-03-16 00:06:27 +0000
commit28aa4cc935023f6f5a92fe20f5463aad522cb150 (patch)
tree1652327db2de8454c2b36937cb1c16815ed6539d /Makefile
parentConsider PORTDIR_OVERLAY when generating possible completions. (diff)
downloadgentoo-bashcomp-28aa4cc935023f6f5a92fe20f5463aad522cb150.tar.gz
gentoo-bashcomp-28aa4cc935023f6f5a92fe20f5463aad522cb150.tar.bz2
gentoo-bashcomp-28aa4cc935023f6f5a92fe20f5463aad522cb150.zip
Update make install.
svn path=/trunk/; revision=26
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 1d4a89b..916a1ff 100644
--- a/Makefile
+++ b/Makefile
@@ -5,10 +5,14 @@ distapp = gentoo-bashcomp
distver := $(shell date --iso | sed -e 's~-~~g')
distpkg := $(distapp)-$(distver)
-PREFIX = ${HOME}/.bash_completion.d
+PREFIX = /usr
install:
- cp gentoo "$(PREFIX)"
+ install -d "$(DESTDIR)$(PREFIX)/share/bash-completion"
+ install -m0644 gentoo "$(DESTDIR)$(PREFIX)/share/bash-completion"
+ install -d "$(DESTDIR)/etc/bash_completion.d"
+ ln -snf "../..$(PREFIX)/share/bash-completion/gentoo" \
+ "$(DESTDIR)/etc/bash_completion.d/gentoo"
dist:
mkdir -p "$(distpkg)"