diff options
Diffstat (limited to 'tox.ini')
-rw-r--r-- | tox.ini | 15 |
1 files changed, 7 insertions, 8 deletions
@@ -1,17 +1,16 @@ [tox] -envlist = py39,py310,py311,py312,pypy3,flake8 -skip_missing_interpreters = True +envlist = py{39,310,311,312,313}-test,pypy3-test,flake8 +skipsdist = True [testenv] -commands = - python setup.py test sitepackages = True - -[testenv:flake8] deps = - flake8 + test: pytest +allowlist_externals = + pytest commands = - python -m flake8 pym + pylint: pylint pym + test: pytest -vv -ra -l -o console_output_style=count {posargs} [flake8] # We initially start small, but we probably want to expand that list with time. |