summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libsoup/libsoup-9999.ebuild')
-rw-r--r--net-libs/libsoup/libsoup-9999.ebuild45
1 files changed, 31 insertions, 14 deletions
diff --git a/net-libs/libsoup/libsoup-9999.ebuild b/net-libs/libsoup/libsoup-9999.ebuild
index d4cba7a..deaf7f7 100644
--- a/net-libs/libsoup/libsoup-9999.ebuild
+++ b/net-libs/libsoup/libsoup-9999.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/libsoup-2.26.2.ebuild,v 1.3 2009/05/21 18:14:56 nirbheek Exp $
+
+EAPI="2"
inherit gnome2 gnome2-live
@@ -9,23 +11,38 @@ HOMEPAGE="http://www.gnome.org/"
LICENSE="LGPL-2"
SLOT="2.4"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug doc ssl"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+# Do NOT build with --disable-debug/--enable-debug=no - gnome2.eclass takes care of that
+IUSE="debug doc gnome ssl"
RDEPEND=">=dev-libs/glib-2.15.3
- >=dev-libs/libxml2-2
- ssl? ( >=net-libs/gnutls-1 )"
+ >=dev-libs/libxml2-2
+ gnome? (
+ net-libs/libproxy
+ >=gnome-base/gconf-2
+ dev-db/sqlite:3 )
+ ssl? ( >=net-libs/gnutls-1 )"
DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.9
- doc? ( >=dev-util/gtk-doc-1 )"
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1 )"
+# test? (
+# www-servers/apache
+# dev-lang/php
+# net-misc/curl )
-DOCS="AUTHORS ChangeLog NEWS README"
+DOCS="AUTHORS NEWS README"
pkg_setup() {
- # Do NOT build with --disable-debug/--enable-debug=no
- if use debug ; then
- G2CONF="${G2CONF} --enable-debug=yes"
- fi
+ G2CONF="${G2CONF}
+ --disable-static
+ $(use_with gnome)
+ $(use_enable ssl)"
+}
+
+src_prepare() {
+ # Fix test to follow POSIX (for x86-fbsd)
+ # No patch to prevent having to eautoreconf
+ sed -e 's/\(test.*\)==/\1=/g' -i configure.in || die "sed failed"
- G2CONF="${G2CONF} $(use_enable ssl)"
+ gnome2-live_src_prepare
}