summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2009-09-10 17:20:45 +0530
committerNirbheek Chauhan <nirbheek@gentoo.org>2009-09-10 17:20:45 +0530
commit01032f1830525ef369a3665171ba2ca146b02b2d (patch)
tree18a4bd5253b98ed2135a6ff1630100e3c2723de0 /app-admin
parentgnome-base/gnome-applets: Bump to 2.27.92 (diff)
downloadgnome-01032f1830525ef369a3665171ba2ca146b02b2d.tar.gz
gnome-01032f1830525ef369a3665171ba2ca146b02b2d.tar.bz2
gnome-01032f1830525ef369a3665171ba2ca146b02b2d.zip
app-admin/sabayon: Bump to 2.27.91
* Uses Xephyr instead of Xnest * Updated translations and documentation
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/sabayon/Manifest2
-rw-r--r--app-admin/sabayon/sabayon-2.27.91.ebuild83
2 files changed, 85 insertions, 0 deletions
diff --git a/app-admin/sabayon/Manifest b/app-admin/sabayon/Manifest
new file mode 100644
index 00000000..462f12d8
--- /dev/null
+++ b/app-admin/sabayon/Manifest
@@ -0,0 +1,2 @@
+DIST sabayon-2.27.91.tar.bz2 686680 RMD160 df0ab37fb2455a5837aa306aa0bfc327740140de SHA1 fbec91615e656d3ef260071edebbad28cfe5dbf7 SHA256 0dba9a9be02183303b381624fcb06c17e67fb07c5727480c42d4239d64895f96
+EBUILD sabayon-2.27.91.ebuild 2417 RMD160 b34674ad3c4229b3d2f3e2e158bdc86df70c27aa SHA1 3ad7ac1ed9508e570fad35981003f917485aeceb SHA256 d4d977be6737e8fabd27b7ebf1beff6f88c58c13f15a647d5f17af8a4e3b5a37
diff --git a/app-admin/sabayon/sabayon-2.27.91.ebuild b/app-admin/sabayon/sabayon-2.27.91.ebuild
new file mode 100644
index 00000000..8eb710d2
--- /dev/null
+++ b/app-admin/sabayon/sabayon-2.27.91.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sabayon/sabayon-2.25.0.ebuild,v 1.1 2009/05/02 19:04:00 eva Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit gnome2 eutils python multilib
+
+DESCRIPTION="Tool to maintain user profiles in a GNOME desktop"
+HOMEPAGE="http://www.gnome.org/projects/sabayon/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# Unfortunately the configure.ac is wildly insufficient, so dependencies have
+# to be got from the RPM .spec file...
+# But the .spec file got removed :/
+COMMON_DEPEND=">=dev-lang/python-2.4
+ >=x11-libs/gtk+-2.6.0
+ >=dev-python/pygtk-2.5.3
+ >=dev-python/pygobject-2.15
+ x11-libs/pango
+ dev-python/python-ldap
+ x11-base/xorg-server[kdrive]"
+
+RDEPEND="${COMMON_DEPEND}
+ dev-python/pyxdg
+ dev-libs/libxml2[python]
+ >=gnome-base/gconf-2.8.1
+ >=dev-python/gconf-python-2.6
+ x11-libs/gksu"
+
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40"
+
+DOCS="AUTHORS ChangeLog ISSUES NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-static
+ --with-distro=gentoo
+ --with-prototype-user=${PN}-admin
+ --enable-console-helper=no"
+
+ einfo "Adding user '${PN}-admin' as the prototype user"
+ # I think /var/lib/sabayon is the correct directory to use here.
+ enewgroup ${PN}-admin
+ enewuser ${PN}-admin -1 -1 "/var/lib/sabayon" "${PN}-admin"
+ # Should we delete the user/group on unmerge?
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Switch gnomesu to gksu; bug #197865
+ sed -i 's/Exec=/Exec=gksu /' admin-tool/sabayon.desktop || die "gksu sed failed"
+ sed -i 's/Exec=/Exec=gksu /' admin-tool/sabayon.desktop.in || die "gksu sed failed"
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_mod_optimize $(python_get_sitedir)/sabayon
+
+ # unfortunately /etc/gconf is CONFIG_PROTECT_MASK'd
+ elog "To apply Sabayon defaults and mandatory settings to all users, put"
+ elog ' include "$(HOME)/.gconf.path.mandatory"'
+ elog "in /etc/gconf/2/local-mandatory.path and put"
+ elog ' include "$(HOME)/.gconf.path.defaults"'
+ elog "in /etc/gconf/2/local-defaults.path."
+ elog "You can safely create these files if they do not already exist."
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/sabayon
+}