summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2009-06-09 16:16:43 +0300
committerMart Raudsepp <leio@gentoo.org>2009-06-09 16:27:55 +0300
commit32ae91db12f55d9e57f68ad03414300f29765847 (patch)
tree3ecfd0683f231b430ed003f84a249009958395be /scripts
parentgnome-base/gdm: Remove 2.24, fix bug 266619 (diff)
downloadgnome-32ae91db12f55d9e57f68ad03414300f29765847.tar.gz
gnome-32ae91db12f55d9e57f68ad03414300f29765847.tar.bz2
gnome-32ae91db12f55d9e57f68ad03414300f29765847.zip
find-split-python.sh: Work correctly with a $PORTDIR that has a different depth than /usr/portage
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/find-split-python.sh4
1 files changed, 2 insertions, 2 deletions
diff --git a/scripts/find-split-python.sh b/scripts/find-split-python.sh
index 2a59a23e..af5069f4 100755
--- a/scripts/find-split-python.sh
+++ b/scripts/find-split-python.sh
@@ -15,8 +15,8 @@ for x in $(find $REPO/dev-python -name "*.ebuild" \
-exec egrep -H "inherit.*gnome-python-common" {} \; |\
cut -f1 -d:)
do
- CAT="$(echo $x |cut -f 4 -d /)"
- PN="$(echo $x |cut -f 5 -d /)"
+ CAT="$(echo ${x#$REPO/} |cut -f 1 -d /)"
+ PN="$(echo ${x#$REPO/} |cut -f 2 -d /)"
if egrep -q G_PY_BINDINGS $x; then
BINDINGS=$(sed -n "/G_PY_BINDINGS/ p" $x | sed "s/G_PY_BINDINGS=\"//;s/\"//")