summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-04-13 05:20:28 +0530
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-04-13 05:20:28 +0530
commit96e0c404da536f71267449744e16437bbf4118d4 (patch)
tree978cf8915bce2e3abe424925e97da4753ee448e9 /www-client/epiphany-extensions
parentapp-editors/gedit: 3.0.0 → 3.0.1 (diff)
downloadgnome-96e0c404da536f71267449744e16437bbf4118d4.tar.gz
gnome-96e0c404da536f71267449744e16437bbf4118d4.tar.bz2
gnome-96e0c404da536f71267449744e16437bbf4118d4.zip
Add www-client/epiphany-extensions-3.0.0
Diffstat (limited to 'www-client/epiphany-extensions')
-rw-r--r--www-client/epiphany-extensions/Manifest2
-rw-r--r--www-client/epiphany-extensions/epiphany-extensions-3.0.0.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/www-client/epiphany-extensions/Manifest b/www-client/epiphany-extensions/Manifest
new file mode 100644
index 00000000..7732bce5
--- /dev/null
+++ b/www-client/epiphany-extensions/Manifest
@@ -0,0 +1,2 @@
+DIST epiphany-extensions-3.0.0.tar.bz2 1598864 RMD160 bb0d2a3d3ab8f4150fce6b1f9562185510555b48 SHA1 0603cb954532265fa2f3b9765109a79216c91199 SHA256 c9984de0912b307fecd0232135c0e3d8c7f0859867b9693221ff12d1c483b724
+EBUILD epiphany-extensions-3.0.0.ebuild 1883 RMD160 1929acf7a757b3ffac8d3a01fbd155143a5113cc SHA1 ef538367ac048610d42dbe50d5ac03cc3f54263a SHA256 b72bf91fe2198a0455274184908770c2820761a62912bdc967d749d237068011
diff --git a/www-client/epiphany-extensions/epiphany-extensions-3.0.0.ebuild b/www-client/epiphany-extensions/epiphany-extensions-3.0.0.ebuild
new file mode 100644
index 00000000..54adae82
--- /dev/null
+++ b/www-client/epiphany-extensions/epiphany-extensions-3.0.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/epiphany-extensions/epiphany-extensions-2.32.0.ebuild,v 1.7 2011/03/22 13:49:29 xarthisius Exp $
+
+EAPI="3"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+PYTHON_DEPEND="2"
+
+inherit gnome2 python
+
+DESCRIPTION="Extensions for the Epiphany web browser"
+HOMEPAGE="http://www.gnome.org/projects/epiphany/extensions.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="dbus examples pcre"
+
+RDEPEND=">=www-client/epiphany-3.0.0
+ app-text/opensp
+ >=dev-libs/glib-2.26.0:2
+ >=dev-libs/libxml2-2.6:2
+ >=x11-libs/gtk+-2.90.4:3
+ net-libs/webkit-gtk:3
+
+ dbus? ( >=dev-libs/dbus-glib-0.34 )
+ pcre? ( >=dev-libs/libpcre-3.9-r2 )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.20
+ >=app-text/gnome-doc-utils-0.3.2"
+# eautoreconf dependencies:
+# gnome-base/gnome-common
+
+# FIXME: Open security issues:
+# XXX: Check if this is still valid
+# FIXME: - adblock ( https://bugzilla.gnome.org/show_bug.cgi?id=595255 )
+
+pkg_setup() {
+ local extensions=""
+ # XXX: Only enable default/useful extensions?
+ extensions="actions auto-reload certificates \
+ error-viewer extensions-manager-ui gestures html5tube \
+ java-console livehttpheaders page-info \
+ push-scroller select-stylesheet \
+ smart-bookmarks soup-fly tab-states"
+ use dbus && extensions="${extensions} rss"
+ use pcre && extensions="${extensions} greasemonkey"
+ use examples && extensions="${extensions} sample"
+
+ G2CONF="${G2CONF}
+ --disable-schemas-compile
+ --disable-maintainer-mode
+ --with-extensions=$(echo "${extensions}" | sed -e 's/[[:space:]]\+/,/g')"
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+ python_set_active_version 2
+}
+
+src_prepare() {
+ gnome2_src_prepare
+ python_convert_shebangs -r 2 .
+}