summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnustep-base/gnustep-back-art/gnustep-back-art-0.12.0.ebuild')
-rw-r--r--gnustep-base/gnustep-back-art/gnustep-back-art-0.12.0.ebuild71
1 files changed, 0 insertions, 71 deletions
diff --git a/gnustep-base/gnustep-back-art/gnustep-back-art-0.12.0.ebuild b/gnustep-base/gnustep-back-art/gnustep-back-art-0.12.0.ebuild
deleted file mode 100644
index 4737937..0000000
--- a/gnustep-base/gnustep-back-art/gnustep-back-art-0.12.0.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="prefix"
-
-inherit gnustep-base
-
-S=${WORKDIR}/gnustep-back-${PV}
-
-DESCRIPTION="libart_lgpl back-end component for the GNUstep GUI Library"
-
-HOMEPAGE="http://www.gnustep.org"
-SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/gnustep-back-${PV}.tar.gz"
-KEYWORDS="~amd64 ~x86 ~x86-solaris"
-SLOT="0"
-LICENSE="LGPL-2.1"
-
-IUSE="opengl xim"
-
-DEPEND="${GNUSTEP_CORE_DEPEND}
- ~gnustep-base/gnustep-gui-${PV}
- opengl? ( virtual/opengl virtual/glu )
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXi
- x11-libs/libXmu
- x11-libs/libXt
- x11-libs/libXft
- x11-libs/libXrender
- dev-libs/expat
- media-libs/fontconfig
- >=media-libs/freetype-2.1.9
- >=media-libs/libart_lgpl-2.3
- gnustep-base/mknfonts
- media-fonts/dejavu
- !virtual/gnustep-back"
-RDEPEND="${DEPEND}"
-
-src_compile() {
- egnustep_env
-
- use opengl && myconf="--enable-glx"
- myconf="$myconf `use_enable xim`"
- myconf="$myconf --enable-server=x11"
- myconf="$myconf --enable-graphics=art"
- econf $myconf || die "configure failed"
-
- egnustep_make
-
- # Create font lists for DejaVu
- einfo "Generating nfonts support files"
- cd Fonts
- mknfonts $(fc-list : file|grep -v '\.gz'|cut -d: -f1)
- # Trim whitepsaces
- for fdir in *\ */; do
- mv "$fdir" `echo $fdir | tr -d [:space:]`
- done
-}
-
-src_install() {
- egnustep_env
-
- gnustep-base_src_install
-
- mkdir -p "${D}/${GNUSTEP_SYSTEM_LIBRARY}/Fonts"
- cp -pPR Fonts/*.nfont "${D}/${GNUSTEP_SYSTEM_LIBRARY}/Fonts"
-}
-