summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kdelibs/files')
-rw-r--r--kde-base/kdelibs/files/4.2.4-CVE-2009-1690.patch82
-rw-r--r--kde-base/kdelibs/files/4.2.4-fixPopupForPlasmaboard.patch43
-rw-r--r--kde-base/kdelibs/files/dist/09_disable_debug_messages_if_not_explicitly_enabled.patch61
-rw-r--r--kde-base/kdelibs/files/dist/20_use_dejavu_as_default_font.patch32
-rw-r--r--kde-base/kdelibs/files/dist/23_solid_no_double_build.patch19
-rw-r--r--kde-base/kdelibs/files/kdelibs-3.5.8-kinit-CVE-2008-1671.patch113
-rw-r--r--kde-base/kdelibs/files/kdelibs-3.5.9-bug_203433_khtml.patch25
-rw-r--r--kde-base/kdelibs/files/kdelibs-3.5.9-bug_219970_khtml.patch90
-rw-r--r--kde-base/kdelibs/files/kdelibs-3.5.9-cursor.patch11
-rw-r--r--kde-base/kdelibs/files/kdelibs-4.2-fixx11h.h.patch22
10 files changed, 0 insertions, 498 deletions
diff --git a/kde-base/kdelibs/files/4.2.4-CVE-2009-1690.patch b/kde-base/kdelibs/files/4.2.4-CVE-2009-1690.patch
deleted file mode 100644
index c274996f..00000000
--- a/kde-base/kdelibs/files/4.2.4-CVE-2009-1690.patch
+++ /dev/null
@@ -1,82 +0,0 @@
-https://bugs.gentoo.org/show_bug.cgi?id=274566
-http://websvn.kde.org/?view=rev&revision=983302
-http://websvn.kde.org/?view=rev&revision=983316
-
---- khtml/html/htmlparser.cpp
-+++ khtml/html/htmlparser.cpp
-@@ -216,7 +216,6 @@
-
- form = 0;
- map = 0;
-- head = 0;
- end = false;
- isindex = 0;
-
-@@ -678,8 +677,7 @@
- case ID_BASE:
- if(!head) {
- head = new HTMLHeadElementImpl(document);
-- e = head;
-- insertNode(e);
-+ insertNode(head.get());
- handled = true;
- }
- break;
-@@ -894,7 +892,7 @@
- case ID_HEAD:
- if(!head && (current->id() == ID_HTML || current->isDocumentNode())) {
- head = new HTMLHeadElementImpl(document);
-- n = head;
-+ n = head.get();
- }
- break;
- case ID_BODY:
-@@ -1800,19 +1798,19 @@
- head = new HTMLHeadElementImpl(document);
- HTMLElementImpl *body = doc()->body();
- int exceptioncode = 0;
-- doc()->documentElement()->insertBefore(head, body, exceptioncode);
-+ doc()->documentElement()->insertBefore(head.get(), body, exceptioncode);
- if ( exceptioncode ) {
- #ifdef PARSER_DEBUG
- kDebug( 6035 ) << "creation of head failed!!!!:" << exceptioncode;
- #endif
-- delete head;
-+ delete head.get();
- head = 0;
- }
-
- // If the body does not exist yet, then the <head> should be pushed as the current block.
- if (head && !body) {
- pushBlock(head->id(), tagPriority(head->id()));
-- setCurrent(head);
-+ setCurrent(head.get());
- }
- }
-
---- khtml/html/htmlparser.h
-+++ khtml/html/htmlparser.h
-@@ -155,7 +155,7 @@
- /*
- * the head element. Needed for crappy html which defines <base> after </head>
- */
-- DOM::HTMLHeadElementImpl *head;
-+ RefPtr<DOM::HTMLHeadElementImpl> head;
-
- /*
- * a possible <isindex> element in the head. Compatibility hack for
---- khtml/svg/SVGList.h
-+++ khtml/svg/SVGList.h
-@@ -97,7 +97,11 @@
-
- Item insertItemBefore(Item newItem, unsigned int index, ExceptionCode&)
- {
-- m_vector.insert(index, newItem);
-+ if (index < m_vector.size()) {
-+ m_vector.insert(index, newItem);
-+ } else {
-+ m_vector.append(newItem);
-+ }
- return newItem;
- }
-
diff --git a/kde-base/kdelibs/files/4.2.4-fixPopupForPlasmaboard.patch b/kde-base/kdelibs/files/4.2.4-fixPopupForPlasmaboard.patch
deleted file mode 100644
index cf6dec7c..00000000
--- a/kde-base/kdelibs/files/4.2.4-fixPopupForPlasmaboard.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-Index: kdelibs/plasma/popupapplet.cpp
-===================================================================
---- kdelibs/plasma/popupapplet.cpp (Revision 976120)
-+++ kdelibs/plasma/popupapplet.cpp (Arbeitskopie)
-@@ -275,11 +275,7 @@
- //stuff out of your Dialog (extenders). Monitor WindowDeactivate events so we can
- //emulate the same kind of behavior as Qt::Popup (close when you click somewhere
- //else.
-- dialog->setWindowFlags(Qt::FramelessWindowHint | Qt::WindowStaysOnTopHint);
-- updateDialogFlags();
-- KWindowSystem::setState(dialog->winId(), NET::SkipTaskbar | NET::SkipPager);
-- dialog->installEventFilter(q);
--
-+
- q->setMinimumSize(QSize(0, 0));
- if (gWidget) {
- Corona *corona = qobject_cast<Corona *>(gWidget->scene());
-@@ -289,14 +285,25 @@
- corona->addOffscreenWidget(gWidget);
- dialog->setGraphicsWidget(gWidget);
- }
-+
-+ dialog->setWindowFlags(Qt::FramelessWindowHint | Qt::WindowStaysOnTopHint | (gWidget->windowFlags() & Qt::X11BypassWindowManagerHint));
- } else if (qWidget) {
- QVBoxLayout *l_layout = new QVBoxLayout(dialog);
- l_layout->setSpacing(0);
- l_layout->setMargin(0);
- l_layout->addWidget(qWidget);
- dialog->adjustSize();
-+
-+ dialog->setWindowFlags(Qt::FramelessWindowHint | Qt::WindowStaysOnTopHint | (qWidget->windowFlags() & Qt::X11BypassWindowManagerHint));
- }
-+ else {
-+ dialog->setWindowFlags(Qt::FramelessWindowHint | Qt::WindowStaysOnTopHint);
-+ }
-+ updateDialogFlags();
-+ KWindowSystem::setState(dialog->winId(), NET::SkipTaskbar | NET::SkipPager);
-+ dialog->installEventFilter(q);
-
-+
- QObject::connect(dialog, SIGNAL(dialogResized()), q, SLOT(dialogSizeChanged()));
- QObject::connect(dialog, SIGNAL(dialogVisible(bool)), q, SLOT(dialogStatusChanged(bool)));
- }
diff --git a/kde-base/kdelibs/files/dist/09_disable_debug_messages_if_not_explicitly_enabled.patch b/kde-base/kdelibs/files/dist/09_disable_debug_messages_if_not_explicitly_enabled.patch
deleted file mode 100644
index 171cb184..00000000
--- a/kde-base/kdelibs/files/dist/09_disable_debug_messages_if_not_explicitly_enabled.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-
-We build with debugging symbols enabled, that's why we get a lot of debugging
-messages on the konsole. This patch disables these messages. Kdebugdialog
-can be used to enable them.
-See also 04_disable_debug_by_default.diff in kdebase-runtime.
-
-In KDE 4.3 trunk this has been committed as r916186.
---- a/kdecore/kdebugrc
-+++ b/kdecore/kdebugrc
-@@ -82,7 +82,7 @@ InfoOutput=4
-
- # KMail
- [5006]
--InfoOutput=2
-+InfoOutput=4
-
- # KitchenSync (Syncing Algorithm)
- [5250]
---- a/kdecore/io/kdebug.cpp
-+++ b/kdecore/io/kdebug.cpp
-@@ -181,6 +181,11 @@ struct KDebugPrivate
- QtOutput = 2,
- SyslogOutput = 3,
- NoOutput = 4,
-+#ifdef QT_NO_DEBUG
-+ DefaultOutput = NoOutput,
-+#else
-+ DefaultOutput = QtOutput,
-+#endif
- Unknown = 5
- };
-
-@@ -313,7 +318,7 @@ struct KDebugPrivate
- }
-
- KConfigGroup cg(config, QString::number(area));
-- int mode = cg.readEntry(key, 2);
-+ int mode = cg.readEntry(key, int(DefaultOutput));
- return OutputMode(mode);
- }
-
---- a/kdecore/io/kdebug.h
-+++ b/kdecore/io/kdebug.h
-@@ -31,12 +31,13 @@
- * @{
- * KDE debug message streams let you and the user control just how many debug
- * messages you see. Debug message printing is controlled by (un)defining
-- * QT_NO_DEBUG when compiling your source. If QT_NO_DEBUG is defined then no debug
-- * messages are printed.
-+ * QT_NO_DEBUG when compiling your source. If QT_NO_DEBUG is defined then debug
-+ * messages are not printed by default but can still be enabled by runtime
-+ * configuration, e.g. via kdebugdialog or by editing kdebugrc.
- */
-
- #if !defined(KDE_NO_DEBUG_OUTPUT)
--# if defined(QT_NO_DEBUG) || defined(QT_NO_DEBUG_OUTPUT) || defined(QT_NO_DEBUG_STREAM)
-+# if defined(QT_NO_DEBUG_OUTPUT) || defined(QT_NO_DEBUG_STREAM)
- # define KDE_NO_DEBUG_OUTPUT
- # endif
- #endif
-
diff --git a/kde-base/kdelibs/files/dist/20_use_dejavu_as_default_font.patch b/kde-base/kdelibs/files/dist/20_use_dejavu_as_default_font.patch
deleted file mode 100644
index 577e8789..00000000
--- a/kde-base/kdelibs/files/dist/20_use_dejavu_as_default_font.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-
-Use DejaVu Sans as default font and adjusts sizes accordingly.
---- a/kdeui/kernel/kglobalsettings.cpp
-+++ b/kdeui/kernel/kglobalsettings.cpp
-@@ -374,7 +374,7 @@
-
- // NOTE: keep in sync with kdebase/workspace/kcontrol/fonts/fonts.cpp
- static const char GeneralId[] = "General";
--static const char DefaultFont[] = "Sans Serif";
-+static const char DefaultFont[] = "DejaVu Sans";
- #ifdef Q_WS_MAC
- static const char DefaultMacFont[] = "Lucida Grande";
- #endif
-@@ -387,13 +387,13 @@
- { GeneralId, "toolBarFont", DefaultMacFont, 11, -1, QFont::SansSerif },
- { GeneralId, "menuFont", DefaultMacFont, 13, -1, QFont::SansSerif },
- #else
-- { GeneralId, "font", DefaultFont, 10, -1, QFont::SansSerif },
-- { GeneralId, "fixed", "Monospace", 10, -1, QFont::TypeWriter },
-+ { GeneralId, "font", DefaultFont, 9, -1, QFont::SansSerif },
-+ { GeneralId, "fixed", "DejaVu Sans Mon", 9, -1, QFont::TypeWriter },
- { GeneralId, "toolBarFont", DefaultFont, 8, -1, QFont::SansSerif },
-- { GeneralId, "menuFont", DefaultFont, 10, -1, QFont::SansSerif },
-+ { GeneralId, "menuFont", DefaultFont, 9, -1, QFont::SansSerif },
- #endif
- { "WM", "activeFont", DefaultFont, 9, QFont::Bold, QFont::SansSerif },// inconsistency
-- { GeneralId, "taskbarFont", DefaultFont, 10, -1, QFont::SansSerif },
-+ { GeneralId, "taskbarFont", DefaultFont, 9, -1, QFont::SansSerif },
- { GeneralId, "smallestReadableFont", DefaultFont, 8, -1, QFont::SansSerif }
- };
-
-
diff --git a/kde-base/kdelibs/files/dist/23_solid_no_double_build.patch b/kde-base/kdelibs/files/dist/23_solid_no_double_build.patch
deleted file mode 100644
index fa71eb97..00000000
--- a/kde-base/kdelibs/files/dist/23_solid_no_double_build.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-
---- a/solid/solid/CMakeLists.txt
-+++ b/solid/solid/CMakeLists.txt
-@@ -194,7 +194,14 @@
- install(FILES org.freedesktop.PowerManagement.Inhibit.xml DESTINATION ${DBUS_INTERFACES_INSTALL_DIR})
-
- ########### static lib for tests ###############
-+macro(AUTOMOC_COPY _from_target _to_target)
-+ set(_srcfile ${CMAKE_CURRENT_BINARY_DIR}/${_from_target}_automoc.cpp)
-+ set(_dstfile ${CMAKE_CURRENT_BINARY_DIR}/${_to_target}_automoc.cpp)
-+ add_custom_command(OUTPUT ${_dstfile} COMMAND ${CMAKE_COMMAND} -E copy
-+ ${_srcfile} ${_dstfile} MAIN_DEPENDENCY ${_srcfile})
-+endmacro(AUTOMOC_COPY _from_target _to_target)
-
-+automoc_copy(solid solid_static)
- kde4_add_library(solid_static STATIC ${solid_LIB_SRCS})
-
- target_link_libraries(solid_static ${QT_QTCORE_LIBRARY} ${QT_QTDBUS_LIBRARY} ${QT_QTXML_LIBRARY} ${QT_QTGUI_LIBRARY})
-
diff --git a/kde-base/kdelibs/files/kdelibs-3.5.8-kinit-CVE-2008-1671.patch b/kde-base/kdelibs/files/kdelibs-3.5.8-kinit-CVE-2008-1671.patch
deleted file mode 100644
index 9ffcd812..00000000
--- a/kde-base/kdelibs/files/kdelibs-3.5.8-kinit-CVE-2008-1671.patch
+++ /dev/null
@@ -1,113 +0,0 @@
---- kinit/start_kdeinit.c
-+++ kinit/start_kdeinit.c
-@@ -37,9 +37,10 @@
- not have this protection, kdeinit will after forking send the new
- PID using the pipe and wait for a signal. This parent will reset the protection
- and SIGUSR1 the process to continue.
-+ returns 1 if pid is valid
- */
-
--static void set_protection( pid_t pid, int enable )
-+static int set_protection( pid_t pid, int enable )
- {
- char buf[ 1024 ];
- int procfile;
-@@ -49,7 +50,7 @@ static void set_protection( pid_t pid, i
- belongs to this user. */
- struct stat st;
- if( lstat( buf, &st ) < 0 || st.st_uid != getuid())
-- return;
-+ return 0;
- }
- procfile = open( buf, O_WRONLY );
- if( procfile >= 0 ) {
-@@ -59,6 +60,7 @@ static void set_protection( pid_t pid, i
- write( procfile, "0", sizeof( "0" ));
- close( procfile );
- }
-+ return 1;
- }
-
- int main(int argc, char **argv)
-@@ -67,14 +69,14 @@ int main(int argc, char **argv)
- int new_argc;
- const char** new_argv;
- char helper_num[ 1024 ];
-- int i;
-+ unsigned i;
- char** orig_environ = NULL;
- char header[ 7 ];
- if( pipe( pipes ) < 0 ) {
- perror( "pipe()" );
- return 1;
- }
-- if( argc > 1000 )
-+ if( argc < 0 || argc > 1000 )
- abort(); /* paranoid */
- set_protection( getpid(), 1 );
- switch( fork()) {
-@@ -82,29 +84,30 @@ int main(int argc, char **argv)
- perror( "fork()" );
- return 1;
- default: /* parent, drop privileges and exec */
--#if defined (HAVE_SETEUID) && !defined (HAVE_SETEUID_FAKE)
-- seteuid(getuid());
--#else
-- setreuid(-1, getuid());
--#endif
-- if (geteuid() != getuid()) {
-+ if (setgid(getgid())) {
-+ perror("setgid()");
-+ return 1;
-+ }
-+ if (setuid(getuid()) || geteuid() != getuid()) {
- perror("setuid()");
- return 1;
- }
- close( pipes[ 0 ] );
- /* read original environment passed by start_kdeinit_wrapper */
- if( read( 0, header, 7 ) == 7 && strncmp( header, "environ", 7 ) == 0 ) {
-- int count;
-- if( read( 0, &count, sizeof( int )) == sizeof( int )) {
-+ unsigned count;
-+ if( read( 0, &count, sizeof( unsigned )) == sizeof( unsigned )
-+ && count && count < (1<<16)) {
- char** env = malloc(( count + 1 ) * sizeof( char* ));
- int ok = 1;
- for( i = 0;
- i < count && ok;
- ++i ) {
-- int len;
-- if( read( 0, &len, sizeof( int )) == sizeof( int )) {
-+ unsigned len;
-+ if( read( 0, &len, sizeof( unsigned )) == sizeof( unsigned )
-+ && len && len < (1<<12)) {
- env[ i ] = malloc( len + 1 );
-- if( read( 0, env[ i ], len ) == len ) {
-+ if( (unsigned) read( 0, env[ i ], len ) == len ) {
- env[ i ][ len ] = '\0';
- } else {
- ok = 0;
-@@ -128,7 +131,7 @@ int main(int argc, char **argv)
- sprintf( helper_num, "%d", pipes[ 1 ] );
- new_argv[ 2 ] = helper_num;
- for( i = 1;
-- i <= argc;
-+ i <= (unsigned) argc;
- ++i )
- new_argv[ i + 2 ] = argv[ i ];
- if( orig_environ )
-@@ -145,10 +148,10 @@ int main(int argc, char **argv)
- if( ret < 0 && errno == EINTR )
- continue;
- if( ret <= 0 ) /* pipe closed or error, exit */
-- return 0;
-+ _exit(0);
- if( pid != 0 ) {
-- set_protection( pid, 0 );
-- kill( pid, SIGUSR1 );
-+ if (set_protection( pid, 0 ))
-+ kill( pid, SIGUSR1 );
- }
- }
- }
diff --git a/kde-base/kdelibs/files/kdelibs-3.5.9-bug_203433_khtml.patch b/kde-base/kdelibs/files/kdelibs-3.5.9-bug_203433_khtml.patch
deleted file mode 100644
index dcb2fc48..00000000
--- a/kde-base/kdelibs/files/kdelibs-3.5.9-bug_203433_khtml.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- trunk/KDE/kdelibs/khtml/html/html_objectimpl.cpp 2007/12/27 04:54:15 753267
-+++ trunk/KDE/kdelibs/khtml/html/html_objectimpl.cpp 2007/12/27 04:54:22 753268
-@@ -243,7 +243,12 @@
-
- _style->deref();
- NodeBaseImpl::attach();
-+
-+ if (m_render) QTimer::singleShot( 0, this, SLOT( slotEmitLoadEvent() ) );
-+}
-
-+void HTMLObjectBaseElementImpl::slotEmitLoadEvent()
-+{
- // ### do this when we are actually finished loading instead
- if (m_render) dispatchHTMLEvent(EventImpl::LOAD_EVENT, false, false);
- }
---- trunk/KDE/kdelibs/khtml/html/html_objectimpl.h 2007/12/27 04:54:15 753267
-+++ trunk/KDE/kdelibs/khtml/html/html_objectimpl.h 2007/12/27 04:54:22 753268
-@@ -62,6 +62,7 @@
- virtual void removeId(const QString& id);
- protected Q_SLOTS:
- void slotRenderAlternative();
-+ void slotEmitLoadEvent();
- protected:
- DOMString m_name;
- };
diff --git a/kde-base/kdelibs/files/kdelibs-3.5.9-bug_219970_khtml.patch b/kde-base/kdelibs/files/kdelibs-3.5.9-bug_219970_khtml.patch
deleted file mode 100644
index 003446d5..00000000
--- a/kde-base/kdelibs/files/kdelibs-3.5.9-bug_219970_khtml.patch
+++ /dev/null
@@ -1,90 +0,0 @@
---- khtml/rendering/render_container.cpp.orig 2008-05-03 09:22:01.000000000 +0200
-+++ khtml/rendering/render_container.cpp 2008-05-03 09:22:47.000000000 +0200
-@@ -79,6 +79,8 @@
- kdDebug( 6040 ) << this << ": " << renderName() << "(RenderObject)::addChild( " << newChild << ": " <<
- newChild->renderName() << ", " << (beforeChild ? beforeChild->renderName() : "0") << " )" << endl;
- #endif
-+ // protect ourselves from deletion
-+ setDoNotDelete(true);
-
- bool needsTable = false;
-
-@@ -159,6 +161,8 @@
- static_cast<RenderText*>(newChild)->setText(textToTransform, true);
- }
- newChild->attach();
-+
-+ setDoNotDelete(false);
- }
-
- RenderObject* RenderContainer::removeChildNode(RenderObject* oldChild)
-@@ -545,7 +549,7 @@
- RenderObject *next = child->nextSibling();
-
- if ( child->isRenderBlock() && child->isAnonymousBlock() && !child->continuation() &&
-- !child->childrenInline() && !child->isTableCell() ) {
-+ !child->childrenInline() && !child->isTableCell() && !child->doNotDelete()) {
- RenderObject *firstAnChild = child->firstChild();
- RenderObject *lastAnChild = child->lastChild();
- if ( firstAnChild ) {
-@@ -560,17 +564,21 @@
- child->previousSibling()->setNextSibling( firstAnChild );
- if ( child->nextSibling() )
- child->nextSibling()->setPreviousSibling( lastAnChild );
-+ if ( child == firstChild() )
-+ m_first = firstAnChild;
-+ if ( child == lastChild() )
-+ m_last = lastAnChild;
- } else {
- if ( child->previousSibling() )
- child->previousSibling()->setNextSibling( child->nextSibling() );
- if ( child->nextSibling() )
- child->nextSibling()->setPreviousSibling( child->previousSibling() );
--
-- }
- if ( child == firstChild() )
-- m_first = firstAnChild;
-+ m_first = child->nextSibling();
- if ( child == lastChild() )
-- m_last = lastAnChild;
-+ m_last = child->previousSibling();
-+ }
-+
- child->setParent( 0 );
- child->setPreviousSibling( 0 );
- child->setNextSibling( 0 );
---- khtml/rendering/render_object.cpp.orig 2008-05-03 09:22:40.000000000 +0200
-+++ khtml/rendering/render_object.cpp 2008-05-03 09:22:47.000000000 +0200
-@@ -178,7 +178,8 @@
- m_isRoot( false ),
- m_afterPageBreak( false ),
- m_needsPageClear( false ),
-- m_containsPageBreak( false )
-+ m_containsPageBreak( false ),
-+ m_doNotDelete(false)
- {
- assert( node );
- if (node->getDocument()->documentElement() == node) setIsRoot(true);
---- khtml/rendering/render_object.h.orig 2008-05-03 09:22:04.000000000 +0200
-+++ khtml/rendering/render_object.h 2008-05-03 09:22:47.000000000 +0200
-@@ -754,6 +754,9 @@
- virtual void deleteInlineBoxes(RenderArena* arena=0) {(void)arena;}
- virtual void detach( );
-
-+ void setDoNotDelete(bool b) { m_doNotDelete = b; }
-+ bool doNotDelete() const { return m_doNotDelete; }
-+
- const QFont &font(bool firstLine) const {
- return style( firstLine )->font();
- }
-@@ -835,7 +838,9 @@
- bool m_needsPageClear : 1;
- bool m_containsPageBreak : 1;
-
-- // ### we have 16 + 24 bits. Cut 8 and save 32
-+ bool m_doNotDelete : 1; // This object should not be auto-deleted
-+
-+ // ### we have 16 + 27 bits.
-
-
- void arenaDelete(RenderArena *arena, void *objectBase);
diff --git a/kde-base/kdelibs/files/kdelibs-3.5.9-cursor.patch b/kde-base/kdelibs/files/kdelibs-3.5.9-cursor.patch
deleted file mode 100644
index 1a9cb993..00000000
--- a/kde-base/kdelibs/files/kdelibs-3.5.9-cursor.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- branches/KDE/3.5/kdelibs/kate/part/katesupercursor.cpp 2008/02/20 11:01:38 777285
-+++ branches/KDE/3.5/kdelibs/kate/part/katesupercursor.cpp 2008/02/20 11:02:18 777286
-@@ -186,7 +186,7 @@
- {
- if (newLine)
- {
-- if (m_line > int(line) || (m_line == int(line) && m_col > int(col)))
-+ if (m_line > int(line) || (m_line == int(line) && m_col >= int(col)))
- {
- if(m_line == int(line))
- m_col -= col;
diff --git a/kde-base/kdelibs/files/kdelibs-4.2-fixx11h.h.patch b/kde-base/kdelibs/files/kdelibs-4.2-fixx11h.h.patch
deleted file mode 100644
index 0263856e..00000000
--- a/kde-base/kdelibs/files/kdelibs-4.2-fixx11h.h.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- kdeui/util/fixx11h.h 2009/03/04 21:28:02 935354
-+++ kdeui/util/fixx11h.h 2009/03/27 14:43:00 945494
-@@ -89,11 +89,16 @@
- #ifdef Bool
- #ifndef FIXX11H_Bool
- #define FIXX11H_Bool
--typedef Bool XBool;
--#undef Bool
--typedef XBool Bool;
-+#ifdef _XTYPEDEF_BOOL /* Xdefs.h has typedef'ed Bool already */
-+ #undef Bool
-+#else
-+ typedef Bool XBool;
-+ #undef Bool
-+ typedef XBool Bool;
-+#endif
- #endif
- #undef Bool
-+#define _XTYPEDEF_BOOL
- #endif
- // template <---
-