aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-11-15 15:17:42 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-11-15 18:30:35 +0100
commit5e13bacd7cf98b2cfd2e7ff56b3f82f74f2b7436 (patch)
treeff7cd24e660b501d91ce82260ca64051e0e6b85b
parentkde-apps/umbrello: 24.11.80 version bump (diff)
downloadkde-5e13bacd7cf98b2cfd2e7ff56b3f82f74f2b7436.tar.gz
kde-5e13bacd7cf98b2cfd2e7ff56b3f82f74f2b7436.tar.bz2
kde-5e13bacd7cf98b2cfd2e7ff56b3f82f74f2b7436.zip
app-cdr/dolphin-plugins-mountiso: 24.11.80 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--app-cdr/dolphin-plugins-mountiso/Manifest1
-rw-r--r--app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.11.80.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/app-cdr/dolphin-plugins-mountiso/Manifest b/app-cdr/dolphin-plugins-mountiso/Manifest
new file mode 100644
index 0000000000..6ab44e39e7
--- /dev/null
+++ b/app-cdr/dolphin-plugins-mountiso/Manifest
@@ -0,0 +1 @@
+DIST dolphin-plugins-24.11.80.tar.xz 318836 BLAKE2B 4b562894d78e63a1ba532a404f1addc8f171af104cddbad1578d84eafdf0f10feb99a4368f3038dbc63147ddb53e5e2a2d4999ccae44f0742611cfa8191bfa9d SHA512 d267c589109e7c3e0c40e31ee8ef02ec10397746a1b6937a6c66b43bcc1489b4b3db21e6488d1ad6a7c28cea6d6099dbc32c7b8a7c88bde0997e208b2983e6e0
diff --git a/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.11.80.ebuild b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.11.80.ebuild
new file mode 100644
index 0000000000..4d0b3e8cd8
--- /dev/null
+++ b/app-cdr/dolphin-plugins-mountiso/dolphin-plugins-mountiso-24.11.80.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_CATEGORY="sdk"
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="mountiso"
+KFMIN=6.5.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=6.7.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for ISO loopback device mounting"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2+"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,widgets]
+ >=kde-apps/dolphin-${PVCUT}:6
+ >=kde-frameworks/kcompletion-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/ktextwidgets-${KFMIN}:6
+ >=kde-frameworks/solid-${KFMIN}:6
+"
+RDEPEND="${DEPEND}
+ >=kde-apps/dolphin-plugins-common-${PV}
+"
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_po_install
+ # qtconcurrent only required by git
+ ecm_punt_qt_module Concurrent
+ # kxmlgui, qtnetwork only required by dropbox
+ ecm_punt_qt_module Network
+ ecm_punt_kf_module XmlGui
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_dropbox=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_makefileactions=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}