aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-06-11 17:57:13 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-06-11 21:33:08 +0200
commit039cd8da9120916196d987f06abbe3a623cfbd32 (patch)
tree2902ae0fceb39b6a2bc525ef205d11b7272615de /dev-libs
parentdev-libs/kopeninghours: 24.05.1 version bump (diff)
downloadkde-039cd8da9120916196d987f06abbe3a623cfbd32.tar.gz
kde-039cd8da9120916196d987f06abbe3a623cfbd32.tar.bz2
kde-039cd8da9120916196d987f06abbe3a623cfbd32.zip
dev-libs/kosmindoormap: 24.05.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/kosmindoormap/Manifest1
-rw-r--r--dev-libs/kosmindoormap/kosmindoormap-24.05.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/kosmindoormap/Manifest b/dev-libs/kosmindoormap/Manifest
new file mode 100644
index 0000000000..67f9bd2adb
--- /dev/null
+++ b/dev-libs/kosmindoormap/Manifest
@@ -0,0 +1 @@
+DIST kosmindoormap-24.05.1.tar.xz 645860 BLAKE2B 73e7e8bf2511e59c06d43f9264ec0733bc10e7cce338174ce5b52f64fdb27b198ccfe10d3722e155367830489577e36691bd2cb861f53725e2cf45434e514d16 SHA512 ab96b13ba9f5ffb9fb7dae1bc4803dcc95525214fe54058634a0c3063dff5191831b1778ac6c758c860e84c923f9e14d1d3edeeacb6b309aab170c608503bb2e
diff --git a/dev-libs/kosmindoormap/kosmindoormap-24.05.1.ebuild b/dev-libs/kosmindoormap/kosmindoormap-24.05.1.ebuild
new file mode 100644
index 0000000000..5c6de80c8c
--- /dev/null
+++ b/dev-libs/kosmindoormap/kosmindoormap-24.05.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.3.0
+QTMIN=6.6.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Data Model and Extraction System for Travel Reservation information"
+HOMEPAGE="https://invent.kde.org/libraries/kosmindoormap"
+
+LICENSE="LGPL-2+"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE="+gui"
+
+# kservice is optional and only used to find and open josm
+RDEPEND="
+ dev-libs/protobuf:=
+ >=dev-qt/qtbase-${QTMIN}:6[gui?,network]
+ sys-libs/zlib
+ gui? (
+ >=dev-libs/kopeninghours-${PVCUT}:6
+ >=dev-libs/kpublictransport-${PVCUT}:6
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kservice-${KFMIN}:6
+ )
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-qt/qtbase-${QTMIN}:6[widgets] )
+"
+BDEPEND="
+ app-alternatives/lex
+ app-alternatives/yacc
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TOOLS_ONLY=$(usex !gui)
+ -DCMAKE_DISABLE_FIND_PACKAGE_OsmTools=ON # we have no use for it
+ )
+ ecm_src_configure
+}