aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-05-13 23:38:05 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-05-14 01:11:31 +0200
commit3be6464175b5450f3b85516b909ddf5078fa9708 (patch)
treee293796d6b6897cb05837599d528ac7c5ad8717d /dev-libs
parentdev-libs/kopeninghours: 24.04.90 version bump (diff)
downloadkde-3be6464175b5450f3b85516b909ddf5078fa9708.tar.gz
kde-3be6464175b5450f3b85516b909ddf5078fa9708.tar.bz2
kde-3be6464175b5450f3b85516b909ddf5078fa9708.zip
dev-libs/kosmindoormap: 24.04.90 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/kosmindoormap/Manifest1
-rw-r--r--dev-libs/kosmindoormap/kosmindoormap-24.04.90.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-libs/kosmindoormap/Manifest b/dev-libs/kosmindoormap/Manifest
new file mode 100644
index 0000000000..69a210c2b8
--- /dev/null
+++ b/dev-libs/kosmindoormap/Manifest
@@ -0,0 +1 @@
+DIST kosmindoormap-24.04.90.tar.xz 645924 BLAKE2B c827214ed42b7b30306f659337c31096a7100af7c09b091d64f994934cf590937f0d2f78870e5b0cded8a82b38c798201593f6b7a8170dc128b931b73d892c71 SHA512 3c3aff70386c33b9f4145a4b38cd1f9b9f2a6b7963005f544fcae310c1e278be48d1d690955baa3b2f9b3b317873efbca40ea8c78924b4fdd628b0edd77708db
diff --git a/dev-libs/kosmindoormap/kosmindoormap-24.04.90.ebuild b/dev-libs/kosmindoormap/kosmindoormap-24.04.90.ebuild
new file mode 100644
index 0000000000..48e9a9cd47
--- /dev/null
+++ b/dev-libs/kosmindoormap/kosmindoormap-24.04.90.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.0.0
+QTMIN=6.6.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Data Model and Extraction System for Travel Reservation information"
+HOMEPAGE="https://invent.kde.org/libraries/kosmindoormap"
+
+LICENSE="LGPL-2+"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE="+gui"
+
+# kservice is optional and only used to find and open josm
+RDEPEND="
+ dev-libs/protobuf:=
+ >=dev-qt/qtbase-${QTMIN}:6[gui?,network]
+ sys-libs/zlib
+ gui? (
+ >=dev-libs/kopeninghours-${PVCUT}:6
+ >=dev-libs/kpublictransport-${PVCUT}:6
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kservice-${KFMIN}:6
+ )
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-qt/qtbase-${QTMIN}:6[widgets] )
+"
+BDEPEND="
+ app-alternatives/lex
+ app-alternatives/yacc
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TOOLS_ONLY=$(usex !gui)
+ -DCMAKE_DISABLE_FIND_PACKAGE_OsmTools=ON # we have no use for it
+ )
+ ecm_src_configure
+}