aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-11-02 23:17:52 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-11-02 23:22:26 +0100
commit0c411f87049f53e639aea2062f38f41c1a180a1e (patch)
treef5e058510418ce81303efd20335f68c82043738a /kde-frameworks
parentkde-frameworks/kxmlgui: 6.8.0 version bump (diff)
downloadkde-0c411f87049f53e639aea2062f38f41c1a180a1e.tar.gz
kde-0c411f87049f53e639aea2062f38f41c1a180a1e.tar.bz2
kde-0c411f87049f53e639aea2062f38f41c1a180a1e.zip
kde-frameworks/purpose: 6.8.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-6.8.0.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
new file mode 100644
index 0000000000..8a27e485b9
--- /dev/null
+++ b/kde-frameworks/purpose/Manifest
@@ -0,0 +1 @@
+DIST purpose-6.8.0.tar.xz 178044 BLAKE2B 90a77d6928504115c7eaabd4b825a9788b8a7f96a3aedfd6bd458bfa08bc331b0c55dd8947893b4bb9b78b4c6ae9eb42a99370b06961302eb1e32f5207fabd23 SHA512 b82370a48de4df8d14c44befe2dc6a7a98ea7cfb2e2bee069c5a146e34669c9e28e52d3de4ece0695cbe67fb3692060aca47e44939737ce3e0c9aa19dfcfc61c
diff --git a/kde-frameworks/purpose/purpose-6.8.0.ebuild b/kde-frameworks/purpose/purpose-6.8.0.ebuild
new file mode 100644
index 0000000000..09ce2a6738
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-6.8.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=6.7.2
+inherit ecm frameworks.kde.org optfeature xdg-utils
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="bluetooth webengine"
+
+# requires running environment
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,network,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ =kde-frameworks/kconfig-${PVCUT}*:6
+ =kde-frameworks/kcoreaddons-${PVCUT}*:6
+ =kde-frameworks/ki18n-${PVCUT}*:6
+ =kde-frameworks/kio-${PVCUT}*:6
+ =kde-frameworks/kirigami-${PVCUT}*:6
+ =kde-frameworks/knotifications-${PVCUT}*:6
+ =kde-frameworks/kservice-${PVCUT}*:6
+ =kde-frameworks/prison-${PVCUT}*:6
+ webengine? (
+ kde-apps/kaccounts-integration:6
+ >=net-libs/accounts-qt-1.17[qt6(+)]
+ )
+"
+RDEPEND="${DEPEND}
+ >=kde-frameworks/kdeclarative-${PVCUT}:6
+ bluetooth? ( =kde-frameworks/bluez-qt-${PVCUT}*:6 )
+ webengine? (
+ >=kde-frameworks/purpose-kaccounts-services-${PVCUT}
+ >=net-libs/accounts-qml-0.7_p20231028[qt6(+)]
+ )
+"
+BDEPEND="webengine? ( dev-util/intltool )"
+
+src_prepare() {
+ ecm_src_prepare
+
+ use bluetooth ||
+ cmake_run_in src/plugins cmake_comment_add_subdirectory bluetooth
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package webengine KAccounts6)
+ )
+
+ ecm_src_configure
+}
+
+src_install() {
+ # Shipped by kde-frameworks/purpose-kaccounts-services package for shared use w/ SLOT 5
+ use webengine && ECM_REMOVE_FROM_INSTALL=(
+ /usr/share/accounts/services/kde/{google-youtube,nextcloud-upload}.service
+ )
+ ecm_src_install
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Send through KDE Connect" kde-misc/kdeconnect
+ fi
+ ecm_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}