summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/ldm/ldm-2.2.7.ebuild')
-rw-r--r--x11-misc/ldm/ldm-2.2.7.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-misc/ldm/ldm-2.2.7.ebuild b/x11-misc/ldm/ldm-2.2.7.ebuild
new file mode 100644
index 0000000..e3d9abe
--- /dev/null
+++ b/x11-misc/ldm/ldm-2.2.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EBZR_REVISION="1420"
+EBZR_REPO_URI="http://bazaar.launchpad.net/~ltsp-upstream/ltsp/ldm-trunk"
+EBZR_BOOTSTRAP="autogen.sh"
+
+inherit bzr autotools
+
+DESCRIPTION="LTSP Display Manager"
+HOMEPAGE="http://www.ltsp.org/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=dev-libs/glib-2.21
+ >=x11-libs/gtk+-2.18
+ app-text/iso-codes
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35.0"
+RDEPEND="${DEPEND} x11-themes/gtk-engines
+ x11-apps/xdm
+ x11-base/xorg-server"
+
+src_unpack() {
+ bzr_src_unpack
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dosym ltsp /usr/share/ldm/themes/default
+
+ # ssh-hostchecker should be executable, but isn't
+ fperms 744 /usr/share/ldm/ssh-hostchecker
+
+ dodoc README
+ dodoc README-DEVELOPMENT-POLICY
+ dodoc LTSP_LOGO_COPYRIGHT
+}