aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am73
1 files changed, 73 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..c412322
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,73 @@
+########
+# doc/ #
+########
+
+dist_doc_DATA = README
+dist_man1_MANS = doc/lua5.3.1 doc/luac5.3.1
+dist_html_DATA = \
+ doc/contents.html doc/index.css doc/logo.gif doc/lua.css doc/manual.css \
+ doc/manual.html doc/osi-certified-72x60.png doc/readme.html
+
+########
+# src/ #
+########
+
+AM_CFLAGS = -Wall
+AM_CPPFLAGS = -I$(builddir)/src # for luaconf.h
+
+luadir = $(includedir)/lua5.3
+lua_HEADERS = src/lua.h src/lualib.h src/lauxlib.h src/lua.hpp
+nodist_lua_HEADERS = src/luaconf.h
+
+lib_LTLIBRARIES = src/liblua5.3.la
+src_liblua5_3_la_LIBADD = $(LIBM)
+src_liblua5_3_la_SOURCES = \
+ src/lapi.c src/lapi.h src/lauxlib.c src/lbaselib.c src/lcode.c src/lcode.h \
+ src/lcorolib.c src/lctype.c src/lctype.h src/ldblib.c src/ldebug.c \
+ src/ldebug.h src/ldo.c src/ldo.h src/ldump.c src/lfunc.c src/lfunc.h \
+ src/lgc.c src/lbitlib.c src/lgc.h src/linit.c src/liolib.c src/llex.c \
+ src/llex.h src/llimits.h src/lmathlib.c src/lmem.c src/lmem.h src/loadlib.c \
+ src/lobject.c src/lobject.h src/lopcodes.c src/lopcodes.h \
+ src/loslib.c src/lparser.c src/lparser.h src/lprefix.h src/lstate.c \
+ src/lstate.h src/lstring.c src/lstring.h src/lstrlib.c src/ltable.c \
+ src/ltable.h src/ltablib.c src/ltm.c src/ltm.h src/lundump.c src/lundump.h \
+ src/lutf8lib.c src/lvm.c src/lvm.h src/lzio.c src/lzio.h
+
+bin_PROGRAMS = lua5.3 luac5.3
+
+lua5_3_SOURCES = src/lua.c
+lua5_3_CPPFLAGS = $(AM_CPPFLAGS) $(READLINE_CFLAGS)
+lua5_3_LDADD = src/liblua5.3.la $(READLINE_LIBS)
+
+luac5_3_SOURCES = src/luac.c
+luac5_3_LDADD = src/liblua5.3.la
+
+EXTRA_DIST = src/luaconf.h.in
+BUILT_SOURCES = src/luaconf.h
+CLEANFILES = $(BUILT_SOURCES)
+
+pkgconfig_DATA = src/lua5.3.pc
+
+edit = $(SED) \
+ -e 's,@prefix[@],$(prefix),g' \
+ -e 's,@datadir[@],$(datadir),g' \
+ -e 's,@libdir[@],$(libdir),g'
+
+src/luaconf.h: $(srcdir)/src/luaconf.h.in
+ rm -f $@ && $(edit) $(srcdir)/src/luaconf.h.in >$@
+
+##########
+# tests/ #
+##########
+
+TESTS = tests/all.lua
+TESTS_ENVIRONMENT = env LUA=$(abs_builddir)/lua5.3 $(abs_srcdir)/test-wrapper.sh
+
+EXTRA_DIST += test-wrapper.sh \
+ tests/all.lua tests/api.lua tests/attrib.lua tests/big.lua tests/bitwise.lua \
+ tests/calls.lua tests/closure.lua tests/code.lua tests/constructs.lua \
+ tests/coroutine.lua tests/db.lua tests/errors.lua tests/events.lua \
+ tests/files.lua tests/gc.lua tests/goto.lua tests/literals.lua \
+ tests/locals.lua tests/main.lua tests/math.lua tests/nextvar.lua \
+ tests/pm.lua tests/sort.lua tests/strings.lua tests/tpack.lua tests/utf8.lua \
+ tests/vararg.lua tests/verybig.lua