summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/luaunbound/luaunbound-9999.ebuild')
-rw-r--r--dev-lua/luaunbound/luaunbound-9999.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/dev-lua/luaunbound/luaunbound-9999.ebuild b/dev-lua/luaunbound/luaunbound-9999.ebuild
index 2f6e813..5662070 100644
--- a/dev-lua/luaunbound/luaunbound-9999.ebuild
+++ b/dev-lua/luaunbound/luaunbound-9999.ebuild
@@ -26,9 +26,13 @@ DEPEND="
DOCS=(README.markdown)
-#all_lua_prepare() {
-#
-#}
+all_lua_prepare() {
+ lua_default
+ sed -r \
+ -e "/^LUA_VERSION/s@5.2@\$\(LUA_IMPL\)\nLD=gcc@" \
+ -e "/^CFLAGS/s@lua-@@" \
+ -i GNUmakefile
+}
each_lua_compile() {
# If we have LuaJIT in the system — we'd prefer FFI version
@@ -50,7 +54,7 @@ each_lua_install() {
if use prosody; then
insinto "/etc/jabber"
- doins "use_unbound.lua"
+ doins "use_unbound.lua"
fi
}