diff options
author | Sam James <sam@gentoo.org> | 2023-01-28 10:14:46 +0000 |
---|---|---|
committer | Sam James <sam@gentoo.org> | 2023-01-28 10:14:46 +0000 |
commit | aa907a42d89ddfd5a7e64d8182a1da35277f2f6e (patch) | |
tree | a6144b444a8371a32970316f186d057268518f52 | |
parent | meson.build: release 1.3.7 (diff) | |
download | pax-utils-aa907a42d89ddfd5a7e64d8182a1da35277f2f6e.tar.gz pax-utils-aa907a42d89ddfd5a7e64d8182a1da35277f2f6e.tar.bz2 pax-utils-aa907a42d89ddfd5a7e64d8182a1da35277f2f6e.zip |
Make headers standalone (missing includes, prep for clang-tidy)
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r-- | paxelf.h | 5 | ||||
-rw-r--r-- | paxldso.h | 4 | ||||
-rw-r--r-- | paxmacho.h | 2 | ||||
-rw-r--r-- | seccomp-bpf.h | 2 | ||||
-rw-r--r-- | security.h | 2 | ||||
-rw-r--r-- | xfuncs.h | 2 |
6 files changed, 17 insertions, 0 deletions
@@ -11,6 +11,11 @@ #ifndef _PAX_ELF_H #define _PAX_ELF_H +#include <stddef.h> +#include <stdint.h> +#include <stdio.h> +#include <sys/types.h> + typedef struct { const void *phdr; const void *shdr; @@ -9,6 +9,10 @@ #ifndef _PAX_LDSO_H #define _PAX_LDSO_H +#include "paxelf.h" +#include "porting.h" +#include "xfuncs.h" + /* * ld.so.cache logic */ @@ -12,6 +12,8 @@ #ifndef _PAX_MACHO_H #define _PAX_MACHO_H +#include <stddef.h> + #include "macho.h" #define MGET(swapped, value) (swapped ? (__typeof__(value))bswap_32(value) : value) diff --git a/seccomp-bpf.h b/seccomp-bpf.h index 80d6d94..21499f7 100644 --- a/seccomp-bpf.h +++ b/seccomp-bpf.h @@ -4,6 +4,8 @@ * See seccomp-bpf.c for details. */ #undef SECCOMP_BPF_AVAILABLE +#include <stdint.h> + #if defined(__aarch64__) /* AARCH64 */ #define SECCOMP_BPF_AVAILABLE @@ -9,6 +9,8 @@ #ifndef _PAX_SECURITY_H #define _PAX_SECURITY_H +#include <stdbool.h> + /* Whether to enable features that significantly impact speed. */ #ifdef SLOW_SECURITY # define USE_SLOW_SECURITY 1 @@ -9,6 +9,8 @@ #ifndef __XFUNCS_H__ #define __XFUNCS_H__ +#include <stddef.h> + char *xstrdup(const char *s); void *xmalloc(size_t size); void *xzalloc(size_t size); |