summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Westermann-Clark <dwc@pobox.com>2009-07-07 12:38:55 -0400
committerKent Fredric <kentfredric@gmail.com>2013-05-03 22:03:54 +1200
commit345612d99b7331e87c25b23f5d4380e067ebd3c3 (patch)
tree0a87479d7b422d63ec54e7a1cea2646f323580c1 /dev-perl
parent[rehash] Migrate/modernize SVN-Notify 2.83 -> 2.830.0 (diff)
downloadperl-overlay-345612d99b7331e87c25b23f5d4380e067ebd3c3.tar.gz
perl-overlay-345612d99b7331e87c25b23f5d4380e067ebd3c3.tar.bz2
perl-overlay-345612d99b7331e87c25b23f5d4380e067ebd3c3.zip
Add remaining ebuilds from my perl-poe overlay
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/POE-Component-SSLify/Manifest2
-rw-r--r--dev-perl/POE-Component-SSLify/POE-Component-SSLify-0.14.ebuild21
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-perl/POE-Component-SSLify/Manifest b/dev-perl/POE-Component-SSLify/Manifest
new file mode 100644
index 000000000..d2f49755b
--- /dev/null
+++ b/dev-perl/POE-Component-SSLify/Manifest
@@ -0,0 +1,2 @@
+DIST POE-Component-SSLify-0.14.tar.gz 11709 RMD160 e8d0b055c544a368ec91341f21afa9a6ebed00da SHA1 602e44bfa328f5e0439bbe93e2746235e41773e6 SHA256 1298ebead43344c6ed1a21ab79f6f7862e243ee79e42e18002b4f49bcc0fa723
+EBUILD POE-Component-SSLify-0.14.ebuild 603 RMD160 67e7b532356c4d6d41c4bae634c8743dea01ab63 SHA1 11db38626985dc35677976d5b043f444885ff3f7 SHA256 3fb14dea694be9db80c0606f75f4b3309b6219094c901382b0c2125692ac1733
diff --git a/dev-perl/POE-Component-SSLify/POE-Component-SSLify-0.14.ebuild b/dev-perl/POE-Component-SSLify/POE-Component-SSLify-0.14.ebuild
new file mode 100644
index 000000000..a32bdafd8
--- /dev/null
+++ b/dev-perl/POE-Component-SSLify/POE-Component-SSLify-0.14.ebuild
@@ -0,0 +1,21 @@
+# Copyright Daniel Westermann-Clark <daniel at acceleration dot net>
+# Distributed under the terms of the GNU General Public License v2
+# $Header$
+
+inherit perl-module
+
+DESCRIPTION="Makes using SSL in the world of POE easy"
+HOMEPAGE="http://search.cpan.org/dist/${PN}/"
+SRC_URI="mirror://cpan/authors/id/A/AP/APOCAL/${P}.tar.gz"
+LICENSE="|| ( Artistic GPL-2 )"
+
+SLOT="0"
+KEYWORDS="~alpha amd64 ~hppa ~ia64 ~mips ppc ~ppc64 ~sparc x86"
+RESTRICT="nomirror"
+
+IUSE="test"
+RDEPEND="dev-lang/perl
+ >=dev-perl/Net-SSLeay-1.30"
+DEPEND="virtual/perl-Module-Build
+ ${RDEPEND}
+ test? ( virtual/perl-Test-Simple )"