aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-07-06 22:07:56 +0200
committerMichał Górny <mgorny@gentoo.org>2011-07-06 22:07:56 +0200
commited850747ab11f3fd6764b8a87ed9e487894a7f70 (patch)
tree570b0b963cbbf41776a9cc8029126b626e709bbe /pmstestsuite/library
parentActually support the thorough mode. (diff)
downloadpms-test-suite-ed850747ab11f3fd6764b8a87ed9e487894a7f70.tar.gz
pms-test-suite-ed850747ab11f3fd6764b8a87ed9e487894a7f70.tar.bz2
pms-test-suite-ed850747ab11f3fd6764b8a87ed9e487894a7f70.zip
Set KEYWORDS in ebuild, not in the eclass.
This will silence repoman and paludis.
Diffstat (limited to 'pmstestsuite/library')
-rw-r--r--pmstestsuite/library/case.py4
1 files changed, 4 insertions, 0 deletions
diff --git a/pmstestsuite/library/case.py b/pmstestsuite/library/case.py
index 3327c33..6e61378 100644
--- a/pmstestsuite/library/case.py
+++ b/pmstestsuite/library/case.py
@@ -207,6 +207,10 @@ class EbuildTestCase(TestCase):
if pf not in self.phase_funcs:
self.phase_funcs[pf] = []
+ # add KEYWORDS to the ebuild
+ self.ebuild_vars['KEYWORDS'] = 'alpha amd64 arm hppa ia64 ' + \
+ 'm68k ~mips ppc ppc64 s390 sh sparc x86'
+
def get_output_files(self):
"""
Get a dict of files to output in the repository for the test case.