aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'pmstestsuite/library/standard/deprecated_vars.py')
-rw-r--r--pmstestsuite/library/standard/deprecated_vars.py12
1 files changed, 5 insertions, 7 deletions
diff --git a/pmstestsuite/library/standard/deprecated_vars.py b/pmstestsuite/library/standard/deprecated_vars.py
index 14d1bd6..a4a4a6b 100644
--- a/pmstestsuite/library/standard/deprecated_vars.py
+++ b/pmstestsuite/library/standard/deprecated_vars.py
@@ -4,10 +4,10 @@
import os.path
-from .dbus_case import DBusEbuildTestCase
-from .ext_cases import DBusFetchingEbuildTestCase
+from pmstestsuite.library.case import EbuildTestCase
+from .ext_cases import FetchingEbuildTestCase
-class AATest(DBusFetchingEbuildTestCase):
+class AATest(FetchingEbuildTestCase):
""" Test whether AA is declared. """
supported_eapis = (range(0, 4), (4,))
@@ -21,7 +21,7 @@ class AATest(DBusFetchingEbuildTestCase):
}
def __init__(self, *args, **kwargs):
- DBusFetchingEbuildTestCase.__init__(self, *args, **kwargs)
+ FetchingEbuildTestCase.__init__(self, *args, **kwargs)
self._expect_fn = os.path.split(self.ebuild_vars['SRC_URI'])[1]
self.ebuild_vars['SRC_URI'] = 'pms_tests_magical_hidden_use? ( %s )' \
% self.ebuild_vars['SRC_URI']
@@ -32,10 +32,9 @@ class AATest(DBusFetchingEbuildTestCase):
else:
expect = ''
- DBusEbuildTestCase.check_dbus_result(self, output, pm)
self.assertEqual(output[0], expect, '${AA}')
-class KVTest(DBusEbuildTestCase):
+class KVTest(EbuildTestCase):
""" Test whether KV is declared. """
supported_eapis = (range(0, 4), (4,))
@@ -46,7 +45,6 @@ class KVTest(DBusEbuildTestCase):
}
def check_dbus_result(self, output, pm):
- DBusEbuildTestCase.check_dbus_result(self, output, pm)
func = self.assertEqual if self.eapi == 4 \
else self.assertNotEqual
func(output[0], '', '${KV}')