summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-06-20 17:46:02 +0000
committerAli Polatel <hawking@gentoo.org>2008-06-20 17:46:02 +0000
commitce0e380e3a91d437277fdd03336eeb56a6e73491 (patch)
treea9150ceaea946577817fddb1547e5e2efc33a23c /Makefile
parentAdded ChangeLog (diff)
downloadpython-updater-ce0e380e3a91d437277fdd03336eeb56a6e73491.tar.gz
python-updater-ce0e380e3a91d437277fdd03336eeb56a6e73491.tar.bz2
python-updater-ce0e380e3a91d437277fdd03336eeb56a6e73491.zip
Splitted checks. Respect PYUPDATER_OPTIONS. Bashified tests. Added man page.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..885ae36
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,25 @@
+# Makefile for python-updater
+MAN_INCLUDE=man.include
+VERSION=$(shell ./python-updater -V)
+FILES=AUTHORS ChangeLog python-updater python-updater.1
+PKGDIR=python-updater-$(VERSION)
+TARBALL=$(PKGDIR)-tar.bz2
+
+all: python-updater.1 tarball
+
+python-updater.1: python-updater $(MAN_INCLUDE)
+ help2man -L en_GB.UTF-8 -Ni $(MAN_INCLUDE) ./python-updater -o $@
+ sed -i -e 's/ in the manpage//' $@
+
+.PHONY: all clean tarball upload
+clean:
+ rm -fr python-updater.1 *.bz2 $(PKGDIR) || true
+tarball:
+ mkdir $(PKGDIR)
+ cp $(FILES) $(PKGDIR)
+ tar cjf $(TARBALL) $(PKGDIR)
+ rm -fr $(PKGDIR)
+upload:
+ scp $(TARBALL) dev.gentoo.org:/space/distfiles-local
+ ssh dev.gentoo.org chmod ug+rw dev.gentoo.org:/space/distfiles-local/$(TARBALL)
+