aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2018-09-23 16:18:33 +0300
committerJimi Huotari <chiitoo@gentoo.org>2018-09-23 17:57:38 +0300
commit182b079cd39004a600b9dddce6d47449574fd5fc (patch)
tree1aa34804485a78180ae20a9f85e9774522e8582c /lxqt-base/lxqt-session
parentlxqt-base/lxqt-themes: move to x11-themes/lxqt-themes (diff)
downloadqt-182b079cd39004a600b9dddce6d47449574fd5fc.tar.gz
qt-182b079cd39004a600b9dddce6d47449574fd5fc.tar.bz2
qt-182b079cd39004a600b9dddce6d47449574fd5fc.zip
lxqt: sync related ebuilds/metadata with the main Gentoo repo tree
With this, the metadata and 9999 ebuilds are in sync with the 0.13.0 versions found via the official Gentoo repository tree, with the following exceptions: - Polkit is optional. - Some of the USE-flags are not used/included in the metadata. - A patch for 'lxqt-config' is not needed. - The handling of translations has been changed upstream, so 'lxqt-meta' does not depend on 'lxqt-l10n' due to file collisions. Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'lxqt-base/lxqt-session')
-rw-r--r--lxqt-base/lxqt-session/lxqt-session-9999.ebuild43
-rw-r--r--lxqt-base/lxqt-session/metadata.xml14
2 files changed, 36 insertions, 21 deletions
diff --git a/lxqt-base/lxqt-session/lxqt-session-9999.ebuild b/lxqt-base/lxqt-session/lxqt-session-9999.ebuild
index 1a65dd68..a534e6d7 100644
--- a/lxqt-base/lxqt-session/lxqt-session-9999.ebuild
+++ b/lxqt-base/lxqt-session/lxqt-session-9999.ebuild
@@ -1,51 +1,60 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit cmake-utils
+
+inherit cmake-utils eapi7-ver
DESCRIPTION="LXQT session manager"
-HOMEPAGE="http://lxqt.org/"
+HOMEPAGE="https://lxqt.org/"
+
+MY_PV="$(ver_cut 1-2)*"
-if [[ ${PV} == *9999* ]]; then
+if [[ ${PV} = *9999* ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/lxde/${PN}.git"
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
else
- SRC_URI="https://github.com/lxde/${PN}/releases/download/${PV}/${P}.tar.xz"
+ SRC_URI="https://downloads.lxqt.org/downloads/${PN}/${PV}/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi
+IUSE="+themes +udev"
+
LICENSE="LGPL-2.1+"
SLOT="0"
-CDEPEND="
- >=dev-libs/libqtxdg-2.0.0
+RDEPEND="
+ >=dev-libs/libqtxdg-3.0.0
dev-qt/qtcore:5
dev-qt/qtdbus:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
dev-qt/qtx11extras:5
- dev-qt/qtxml:5
kde-frameworks/kwindowsystem:5[X]
- lxqt-base/liblxqt
+ =lxqt-base/liblxqt-${MY_PV}
x11-libs/libX11
x11-misc/xdg-user-dirs
+ themes? ( =x11-themes/lxqt-themes-${MY_PV} )
+ udev? ( virtual/libudev )
+ !lxqt-base/lxqt-common
"
-DEPEND="${CDEPEND}
+DEPEND="${RDEPEND}
dev-qt/linguist-tools:5
- dev-util/intltool
- >=dev-util/lxqt-build-tools-0.3.1
- sys-devel/gettext
- virtual/pkgconfig
+ >=dev-util/lxqt-build-tools-0.5.0
"
-RDEPEND="${CDEPEND}"
src_configure() {
- local mycmakeargs=( -DPULL_TRANSLATIONS=OFF )
+ local mycmakeargs=(
+ -DWITH_LIBUDEV=$(usex udev)
+ -DPULL_TRANSLATIONS=OFF
+ )
cmake-utils_src_configure
}
src_install(){
cmake-utils_src_install
doman lxqt-config-session/man/*.1 lxqt-session/man/*.1
+
+ echo XDG_CONFIG_DIRS=\"${EPREFIX}/usr/share\" >> 91lxqt-config-dir
+ doenvd 91lxqt-config-dir
}
diff --git a/lxqt-base/lxqt-session/metadata.xml b/lxqt-base/lxqt-session/metadata.xml
index a40a83a9..90404bed 100644
--- a/lxqt-base/lxqt-session/metadata.xml
+++ b/lxqt-base/lxqt-session/metadata.xml
@@ -1,8 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>lxqt@gentoo.org</email>
- <name>LXQt</name>
- </maintainer>
+ <maintainer type="project">
+ <email>lxqt@gentoo.org</email>
+ <name>LXQt</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">lxqt/lxqt-session</remote-id>
+ </upstream>
+ <use>
+ <flag name="themes">Install LXQt themes and graphics</flag>
+ </use>
</pkgmetadata>