aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 772064a..8e7a5c3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -327,8 +327,8 @@ echo "int main(void) { return 0; }" > libctest.c
$CC $CFLAGS $CPPFLAGS $LDFLAGS -o libctest libctest.c
LIBC_VERSION=$(
$READELF -d libctest | \
- $EGREP NEEDED.*libc\\.so | \
- $AWK '{print $NF}' | sed -e ['s:\[::' -e 's:\]::']
+ $EGREP 'NEEDED.* \@<:@libc\.so' | \
+ $AWK '{print $NF}' | [sed -e 's:\[::' -e 's:\]::']
)
rm -f libctest*
if test "$LIBC_VERSION"x = x ; then