aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 2744542..b94bd9b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -16,3 +16,9 @@ sandbox_SOURCES = \
environ.c \
sandbox.h \
sandbox.c
+
+install-exec-hook:
+ sed -i.tmp \
+ 's:__SANDBOX_TESTING:\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00\x00:' \
+ $(DESTDIR)$(bindir)/sandbox
+ rm -f $(DESTDIR)$(bindir)/sandbox.tmp