aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Schubert <mschu.dev@gmail.com>2024-06-17 11:47:35 +0000
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-06-19 12:14:01 +0200
commit08ad6b68dc1ad2a87a37b8e682e728efb2c90804 (patch)
tree14b7fb49da517376adaa01d2d3187a1fdeae8d5c
parentdev-python/conda-inject: add ebuild (diff)
downloadsci-08ad6b68dc1ad2a87a37b8e682e728efb2c90804.tar.gz
sci-08ad6b68dc1ad2a87a37b8e682e728efb2c90804.tar.bz2
sci-08ad6b68dc1ad2a87a37b8e682e728efb2c90804.zip
dev-python/immutables: add ebuild
Signed-off-by: Michael Schubert <mschu.dev@gmail.com> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/immutables/Manifest1
-rw-r--r--dev-python/immutables/immutables-0.20.ebuild21
-rw-r--r--dev-python/immutables/metadata.xml16
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/immutables/Manifest b/dev-python/immutables/Manifest
new file mode 100644
index 000000000..dfee7ecc9
--- /dev/null
+++ b/dev-python/immutables/Manifest
@@ -0,0 +1 @@
+DIST immutables-0.20.tar.gz 88933 BLAKE2B 07ae33ea62e85ea8c9b26a7e634f018b6e614ecd493faa74cdbdb20864b6af78b30fbadd1c21d9b9e3e971086893dcc7053ba88f8c78d7dbb588d54b8a9d0175 SHA512 1b74236517964573fd26072b6bf1b8a93456822b2b6ccc5f544f8a49b91f2e0bd110ef2ac23358ba14deceaaee8dde6f24e5589e9078dce961a7b9d4fcd2d3bd
diff --git a/dev-python/immutables/immutables-0.20.ebuild b/dev-python/immutables/immutables-0.20.ebuild
new file mode 100644
index 000000000..8cd5bf37b
--- /dev/null
+++ b/dev-python/immutables/immutables-0.20.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit pypi distutils-r1
+
+DESCRIPTION="A high-performance immutable mapping type for Python"
+HOMEPAGE="https://pypi.org/project/immutables/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="test? ( dev-python/mypy[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
diff --git a/dev-python/immutables/metadata.xml b/dev-python/immutables/metadata.xml
new file mode 100644
index 000000000..1bec01ba5
--- /dev/null
+++ b/dev-python/immutables/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mschu.dev@gmail.com</email>
+ <name>Michael Schubert</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">MagicStack/immutables</remote-id>
+ <remote-id type="pypi">immutables</remote-id>
+ </upstream>
+</pkgmetadata>