aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-05-07 22:16:00 +0200
committerAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-06-27 14:20:40 +0200
commit3ae32aae9627d1e379da3e3a6cec9063ff54f67f (patch)
tree7bbedc2a2efb332bf8c842547590c1228f6d6aec
parentsci-physics/photos: new package, add 3.64 (diff)
downloadsci-3ae32aae9627d1e379da3e3a6cec9063ff54f67f.tar.gz
sci-3ae32aae9627d1e379da3e3a6cec9063ff54f67f.tar.bz2
sci-3ae32aae9627d1e379da3e3a6cec9063ff54f67f.zip
sci-physics/evtgen: new package, 02.02.01
Co-authored-by: Andrew Nowa Ammerlaan <andrewammerlaan@gentoo.org> Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de>
-rw-r--r--sci-physics/evtgen/Manifest1
-rw-r--r--sci-physics/evtgen/evtgen-02.02.01.ebuild39
-rw-r--r--sci-physics/evtgen/metadata.xml23
3 files changed, 63 insertions, 0 deletions
diff --git a/sci-physics/evtgen/Manifest b/sci-physics/evtgen/Manifest
new file mode 100644
index 000000000..174d16349
--- /dev/null
+++ b/sci-physics/evtgen/Manifest
@@ -0,0 +1 @@
+DIST evtgen-02.02.01.tar.gz 2941525 BLAKE2B 8672f2d2e7452ba2330180a7e385d020372bdb436d22b12507ee22344f5013b439f68817e70ed50afbc3585beb15f01b0c29ee35dcbbaac8ec1ee0f8d573b3e2 SHA512 652424dae1d3e3d69c19fa946cd00e61ca5117e38eee20a41a98972374d79261fe7267311c06ecab497729f31e5842e340d6739434f09e5088972c95d2ce9c17
diff --git a/sci-physics/evtgen/evtgen-02.02.01.ebuild b/sci-physics/evtgen/evtgen-02.02.01.ebuild
new file mode 100644
index 000000000..32c0ab3a8
--- /dev/null
+++ b/sci-physics/evtgen/evtgen-02.02.01.ebuild
@@ -0,0 +1,39 @@
+EAPI=8
+
+CMAKE_MAKEFILE_GENERATOR="emake"
+
+inherit cmake
+
+MY_PN="EvtGen"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="EvtGen is a Monte Carlo event generator that simulates the decays"
+HOMEPAGE="https://evtgen.hepforge.org/"
+SRC_URI="https://evtgen.hepforge.org/downloads?f=${MY_P}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}/R$(ver_rs 1-2 '-')"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+hepmc3 pythia photos tauola"
+
+RDEPEND="
+ !hepmc3? ( sci-physics/hepmc:2= )
+ hepmc3? ( sci-physics/hepmc:3= )
+ pythia? ( >=sci-physics/pythia-8.3.0:= )
+ photos? ( >=sci-physics/photos-3.64:= )
+ tauola? ( >=sci-physics/tauola-1.1.8:= )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DEVTGEN_HEPMC3=$(usex hepmc3 ON OFF)
+ -DHEPMC3_ROOT_DIR="${ESYSROOT}/usr"
+ -DEVTGEN_PYTHIA=$(usex pythia ON OFF)
+ $(usex pythia -DPYTHIA8_ROOT_DIR="${ESYSROOT}/usr")
+ -DEVTGEN_PHOTOS=$(usex photos ON OFF)
+ -DEVTGEN_TAUOLA=$(usex tauola ON OFF)
+ )
+ cmake_src_configure
+}
diff --git a/sci-physics/evtgen/metadata.xml b/sci-physics/evtgen/metadata.xml
new file mode 100644
index 000000000..08f4b4aec
--- /dev/null
+++ b/sci-physics/evtgen/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alexander@neuwirth-informatik.de</email>
+ <name>Alexander Puck Neuwirth</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-physics@gentoo.org</email>
+ <name>Gentoo Physics Project</name>
+ </maintainer>
+
+ <longdescription lang="en">
+ EvtGen is a Monte Carlo event generator that simulates the decays of heavy flavour particles, primarily B and D mesons. It contains a range of decay models for intermediate and final states containing scalar, vector and tensor mesons or resonances, as well as leptons, photons and baryons. Decay amplitudes are used to generate each branch of a given full decay tree, taking into account angular and time-dependent correlations which allows for the simulation of CP-violating processes. Originally written by Anders Ryd and David Lange, this package is used by many particle physics experiments worldwide, including ATLAS, BaBar, Belle(-II), BES III, CDF, CLEO(-c), CMS, D0, and LHCb. The maintenance and development of the package is now performed by the particle physics group at the University of Warwick (in particular by John Back, Michal Kreps, and Thomas Latham).
+ </longdescription>
+
+ <use>
+ <flag name="pythia">Build with pythia</flag>
+ <flag name="photos">Build with photos</flag>
+ <flag name="tauola">Build with tauola</flag>
+ <flag name="hepmc3">Build with hepmc version 3 support, else hepmc version2 is used</flag>
+ </use>
+</pkgmetadata>