aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Schubert <mschu.dev@gmail.com>2024-06-17 21:42:14 +0000
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-06-19 12:14:20 +0200
commitc1fc331978eedc90dc53ce4cd70a106d0526caa8 (patch)
treeb39664bce0fc01eb4ea87822655535c936292a2c
parentdev-python/smart-open: py3.12 compat; disable tests (broken in py3.11) (diff)
downloadsci-c1fc331978eedc90dc53ce4cd70a106d0526caa8.tar.gz
sci-c1fc331978eedc90dc53ce4cd70a106d0526caa8.tar.bz2
sci-c1fc331978eedc90dc53ce4cd70a106d0526caa8.zip
dev-python/snakemake: add version 8
Signed-off-by: Michael Schubert <mschu.dev@gmail.com> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/snakemake/Manifest1
-rw-r--r--dev-python/snakemake/snakemake-8.14.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/snakemake/Manifest b/dev-python/snakemake/Manifest
index eca03bc0e..3195e9070 100644
--- a/dev-python/snakemake/Manifest
+++ b/dev-python/snakemake/Manifest
@@ -1 +1,2 @@
DIST snakemake-7.32.4.gh.tar.gz 8885863 BLAKE2B 6bb7ff4722dd06f0edf5e8079b42f5e54d6f55f41e2987b7dae7f9b75df0d4d836138e28340e5977107a5cc0b5afe793b0d7897c501246cc1b4340eb4eca2f17 SHA512 34fef61528b18facab798652c88ed5c698ef02161e023255fdd024b7c7781c4e582cdb04b2740fdff9b6f3600acaec719742984acee57920bb48ef3b5af99d9a
+DIST snakemake-8.14.0.gh.tar.gz 8662241 BLAKE2B fc36722b00cb3da11e836d5c521fe6600d176fd6fc3bd8a39336bc6a3d34bfcb689727d9990351cde247e377dca1131bda5dd84852a32ddb91fed44aa62c020e SHA512 68a0aabeed435e032d01f4d38d37c4b37ed7f624bf3768a1654daccdbf95ceb06646d7302ca04ea4f20695ec9706e015d146794aa000ec108d18d6ad09f3671b
diff --git a/dev-python/snakemake/snakemake-8.14.0.ebuild b/dev-python/snakemake/snakemake-8.14.0.ebuild
new file mode 100644
index 000000000..1c601d4fa
--- /dev/null
+++ b/dev-python/snakemake/snakemake-8.14.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Make-like task language"
+HOMEPAGE="https://snakemake.readthedocs.io"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# cannot import name '_helpers' from 'google.cloud'
+RESTRICT="test"
+
+BDEPEND="
+ dev-python/tomli[${PYTHON_USEDEP}]
+ test? (
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/google-api-python-client[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ net-libs/google-cloud-cpp
+ )
+"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/immutables[${PYTHON_USEDEP}]
+ dev-python/ConfigArgParse[${PYTHON_USEDEP}]
+ dev-python/connection_pool[${PYTHON_USEDEP}]
+ dev-python/datrie[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/GitPython[${PYTHON_USEDEP}]
+ dev-python/humanfriendly[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/nbformat[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/reretry[${PYTHON_USEDEP}]
+ dev-python/smart-open[${PYTHON_USEDEP}]
+ dev-python/snakemake-interface-executor-plugins[${PYTHON_USEDEP}]
+ dev-python/snakemake-interface-common[${PYTHON_USEDEP}]
+ dev-python/snakemake-interface-storage-plugins[${PYTHON_USEDEP}]
+ dev-python/snakemake-interface-report-plugins[${PYTHON_USEDEP}]
+ dev-python/stopit[${PYTHON_USEDEP}]
+ dev-python/tabulate[${PYTHON_USEDEP}]
+ dev-python/throttler[${PYTHON_USEDEP}]
+ dev-python/toposort[${PYTHON_USEDEP}]
+ dev-python/wrapt[${PYTHON_USEDEP}]
+ dev-python/yte[${PYTHON_USEDEP}]
+ dev-python/dpath[${PYTHON_USEDEP}]
+ dev-python/conda-inject[${PYTHON_USEDEP}]
+ sci-mathematics/pulp[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinxcontrib-napoleon \
+ dev-python/sphinx-argparse \
+ dev-python/sphinx-rtd-theme \
+ dev-python/docutils \
+ dev-python/recommonmark \
+ dev-python/myst-parser
+distutils_enable_tests pytest