aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-07 14:41:56 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-09-07 14:56:22 +0200
commit62113d3ad5aa7336888fea7ba6d5237e175df5e4 (patch)
treeb4f0692ebf9960f924ebb25c84120a63cc739d80 /sci-biology/open-ephys-gui
parentsci-misc/europa-bin: add new package (diff)
downloadsci-62113d3ad5aa7336888fea7ba6d5237e175df5e4.tar.gz
sci-62113d3ad5aa7336888fea7ba6d5237e175df5e4.tar.bz2
sci-62113d3ad5aa7336888fea7ba6d5237e175df5e4.zip
sci-biology/open-ephys-gui: add version 0.5.5
Closes: https://github.com/gentoo/sci/pull/1111 Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-biology/open-ephys-gui')
-rw-r--r--sci-biology/open-ephys-gui/Manifest1
-rw-r--r--sci-biology/open-ephys-gui/files/open-ephys-gui-0.5.5.patch12
-rw-r--r--sci-biology/open-ephys-gui/open-ephys-gui-0.5.2.2.ebuild2
-rw-r--r--sci-biology/open-ephys-gui/open-ephys-gui-0.5.5.ebuild80
-rw-r--r--sci-biology/open-ephys-gui/open-ephys-gui-9999.ebuild40
-rw-r--r--sci-biology/open-ephys-gui/open-ephys-gui-99999999.ebuild40
6 files changed, 132 insertions, 43 deletions
diff --git a/sci-biology/open-ephys-gui/Manifest b/sci-biology/open-ephys-gui/Manifest
index f4b770e24..9f8d8eeac 100644
--- a/sci-biology/open-ephys-gui/Manifest
+++ b/sci-biology/open-ephys-gui/Manifest
@@ -1 +1,2 @@
DIST open-ephys-gui-0.5.2.2.tar.gz 64533170 BLAKE2B dc70c3eca6a8fbc7c4f6e84580fa6d5b31b837fedbdff20f532e3c01c764cbc3c51637e4fd678d048c78b6f79b4b4a5cd4d437125beeaf712f6f322e82579c85 SHA512 b6369bb0abd8ca18ff225cffab04a24915865647ee1ab5b6d83d5d6fbda3bc64d1b7db04c23deb8d29b8ff378e703b88cfa9d409f4cde62a3af34a7984427219
+DIST open-ephys-gui-0.5.5.tar.gz 63347783 BLAKE2B 8f3ab3c20e23dd4f613e2ed47dca1827ddbcc5e95be5ca12dfeefdc84611653d531d629b78049397fd4951d558f63531ea2265d13e629c8da793fc20090d1075 SHA512 b835a7f8bb3eeb08ec77f6d14f988d6278b2f5b1966fbf8bec55d429c9cee36050cf574dd78a2ebad4adc5c681bcec5b64dcfb1ec87e548c55e2bf1bff2eb2dc
diff --git a/sci-biology/open-ephys-gui/files/open-ephys-gui-0.5.5.patch b/sci-biology/open-ephys-gui/files/open-ephys-gui-0.5.5.patch
new file mode 100644
index 000000000..77e401639
--- /dev/null
+++ b/sci-biology/open-ephys-gui/files/open-ephys-gui-0.5.5.patch
@@ -0,0 +1,12 @@
+# Add 'Gentoo' build type
+
+--- ../CMakeLists.txt 2019-12-02 22:29:24.021065669 -0300
++++ ../CMakeLists.txt 2019-12-02 22:29:11.251065418 -0300
+@@ -123,6 +123,7 @@
+ if(${CMAKE_BUILD_TYPE} STREQUAL "Debug")
+
+ elseif (${CMAKE_BUILD_TYPE} STREQUAL "Release")
++ elseif (${CMAKE_BUILD_TYPE} STREQUAL "Gentoo")
+ else()
+ message(FATAL_ERROR "Invalid build type")
+ endif()
diff --git a/sci-biology/open-ephys-gui/open-ephys-gui-0.5.2.2.ebuild b/sci-biology/open-ephys-gui/open-ephys-gui-0.5.2.2.ebuild
index b0266e0ac..b4cbc6d8f 100644
--- a/sci-biology/open-ephys-gui/open-ephys-gui-0.5.2.2.ebuild
+++ b/sci-biology/open-ephys-gui/open-ephys-gui-0.5.2.2.ebuild
@@ -5,7 +5,7 @@ EAPI=7
inherit cmake
DESCRIPTION="Processing, recording, and visualizing multichannel ephys data"
-HOMEPAGE="http://www.open-ephys.org/gui/"
+HOMEPAGE="https://open-ephys.org/gui/"
LICENSE="GPL-3"
if [[ ${PV} == "9999" ]] ; then
diff --git a/sci-biology/open-ephys-gui/open-ephys-gui-0.5.5.ebuild b/sci-biology/open-ephys-gui/open-ephys-gui-0.5.5.ebuild
new file mode 100644
index 000000000..1c2b20e24
--- /dev/null
+++ b/sci-biology/open-ephys-gui/open-ephys-gui-0.5.5.ebuild
@@ -0,0 +1,80 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit cmake udev
+
+DESCRIPTION="Processing, recording, and visualizing multichannel ephys data"
+HOMEPAGE="https://open-ephys.org/gui/"
+LICENSE="GPL-3"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/open-ephys/plugin-GUI"
+ EGIT_BRANCH="master"
+ Suffix=${EGIT_BRANCH}
+ SubDir=${P}
+elif [[ ${PV} == "99999999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/open-ephys/plugin-GUI"
+ EGIT_BRANCH="development"
+ Suffix=${EGIT_BRANCH}
+ SubDir=${P}
+else
+ SRC_URI="https://github.com/open-ephys/plugin-GUI/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ Suffix=${PV}
+ SubDir="plugin-GUI-${PV}"
+ S="${WORKDIR}/${SubDir}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+SLOT="${PV}"
+IUSE="jack"
+
+DEPEND="
+ media-libs/alsa-lib
+ media-libs/freeglut
+ media-libs/freetype
+ x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/libXinerama
+ jack? ( || ( media-sound/jack-audio-connection-kit media-sound/jack2 ) )
+"
+RDEPEND="${DEPEND}"
+
+BUILD_DIR="${S}/Build"
+PATCHES=( "${FILESDIR}"/${P}.patch )
+
+QA_PREBUILT="opt/open-ephys-*/shared/*.so"
+QA_PRESTRIPPED="
+ opt/open-ephys-*/plugins/*.so
+ opt/open-ephys-*/open-ephys
+"
+
+src_prepare() {
+ cmake_src_prepare
+
+ if use jack; then
+ sed -i 's/JUCE_APP_VERSION=/JUCE_JACK=1\n JUCE_APP_VERSION=/' "${WORKDIR}/${SubDir}/CMakeLists.txt" || die "Sed failed!"
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=( -DCMAKE_SKIP_RPATH=ON )
+ cmake_src_configure
+}
+
+src_install() {
+ dodir opt/open-ephys-"${Suffix}"/ lib/udev/rules.d/
+ cp -R "${BUILD_DIR}"/Gentoo/* "${ED}"/opt/open-ephys-"${Suffix}"/
+ udev_newrules "${WORKDIR}"/"${SubDir}"/Resources/Scripts/40-open-ephys.rules 40-open-ephys-"${Suffix}".rules
+ dosym ../../opt/open-ephys-"${Suffix}"/open-ephys usr/bin/open-ephys-"${Suffix}"
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}
diff --git a/sci-biology/open-ephys-gui/open-ephys-gui-9999.ebuild b/sci-biology/open-ephys-gui/open-ephys-gui-9999.ebuild
index b0266e0ac..1c2b20e24 100644
--- a/sci-biology/open-ephys-gui/open-ephys-gui-9999.ebuild
+++ b/sci-biology/open-ephys-gui/open-ephys-gui-9999.ebuild
@@ -2,38 +2,35 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake
+inherit cmake udev
DESCRIPTION="Processing, recording, and visualizing multichannel ephys data"
-HOMEPAGE="http://www.open-ephys.org/gui/"
+HOMEPAGE="https://open-ephys.org/gui/"
LICENSE="GPL-3"
if [[ ${PV} == "9999" ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/open-ephys/plugin-GUI"
EGIT_BRANCH="master"
- Suffix=$EGIT_BRANCH
+ Suffix=${EGIT_BRANCH}
SubDir=${P}
elif [[ ${PV} == "99999999" ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/open-ephys/plugin-GUI"
EGIT_BRANCH="development"
- Suffix=$EGIT_BRANCH
+ Suffix=${EGIT_BRANCH}
SubDir=${P}
else
SRC_URI="https://github.com/open-ephys/plugin-GUI/archive/v${PV}.tar.gz -> ${P}.tar.gz"
Suffix=${PV}
SubDir="plugin-GUI-${PV}"
- S="${WORKDIR}/$SubDir"
+ S="${WORKDIR}/${SubDir}"
KEYWORDS="~amd64 ~x86"
fi
SLOT="${PV}"
IUSE="jack"
-BDEPEND="
- <sys-devel/gcc-9
-"
DEPEND="
media-libs/alsa-lib
media-libs/freeglut
@@ -41,17 +38,17 @@ DEPEND="
x11-libs/libXrandr
x11-libs/libXcursor
x11-libs/libXinerama
- jack? ( media-sound/jack-audio-connection-kit )
+ jack? ( || ( media-sound/jack-audio-connection-kit media-sound/jack2 ) )
"
RDEPEND="${DEPEND}"
-BUILD_DIR="$S/Build"
+BUILD_DIR="${S}/Build"
PATCHES=( "${FILESDIR}"/${P}.patch )
-QA_PREBUILT="opt/open-ephys-0.5.2.2/shared/*.so"
+QA_PREBUILT="opt/open-ephys-*/shared/*.so"
QA_PRESTRIPPED="
- opt/open-ephys-0.5.2.2/plugins/*.so
- opt/open-ephys-0.5.2.2/open-ephys
+ opt/open-ephys-*/plugins/*.so
+ opt/open-ephys-*/open-ephys
"
src_prepare() {
@@ -68,15 +65,16 @@ src_configure() {
}
src_install() {
- dodir opt/open-ephys-"$Suffix"/ lib/udev/rules.d/
- cp -R "${BUILD_DIR}"/Gentoo/* "${ED}"/opt/open-ephys-"$Suffix"/
- cp -R "${WORKDIR}"/"${SubDir}"/Resources/Scripts/40-open-ephys.rules "${ED}"/lib/udev/rules.d/
- dosym ../../opt/open-ephys-"$Suffix"/open-ephys usr/bin/open-ephys-"$Suffix"
+ dodir opt/open-ephys-"${Suffix}"/ lib/udev/rules.d/
+ cp -R "${BUILD_DIR}"/Gentoo/* "${ED}"/opt/open-ephys-"${Suffix}"/
+ udev_newrules "${WORKDIR}"/"${SubDir}"/Resources/Scripts/40-open-ephys.rules 40-open-ephys-"${Suffix}".rules
+ dosym ../../opt/open-ephys-"${Suffix}"/open-ephys usr/bin/open-ephys-"${Suffix}"
}
pkg_postinst() {
- ewarn " "
- ewarn "You must restart the udev service in order to allow your computer to"
- ewarn "communicate with the Open Ephys acquisition board."
- ewarn " "
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
}
diff --git a/sci-biology/open-ephys-gui/open-ephys-gui-99999999.ebuild b/sci-biology/open-ephys-gui/open-ephys-gui-99999999.ebuild
index b0266e0ac..1c2b20e24 100644
--- a/sci-biology/open-ephys-gui/open-ephys-gui-99999999.ebuild
+++ b/sci-biology/open-ephys-gui/open-ephys-gui-99999999.ebuild
@@ -2,38 +2,35 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake
+inherit cmake udev
DESCRIPTION="Processing, recording, and visualizing multichannel ephys data"
-HOMEPAGE="http://www.open-ephys.org/gui/"
+HOMEPAGE="https://open-ephys.org/gui/"
LICENSE="GPL-3"
if [[ ${PV} == "9999" ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/open-ephys/plugin-GUI"
EGIT_BRANCH="master"
- Suffix=$EGIT_BRANCH
+ Suffix=${EGIT_BRANCH}
SubDir=${P}
elif [[ ${PV} == "99999999" ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/open-ephys/plugin-GUI"
EGIT_BRANCH="development"
- Suffix=$EGIT_BRANCH
+ Suffix=${EGIT_BRANCH}
SubDir=${P}
else
SRC_URI="https://github.com/open-ephys/plugin-GUI/archive/v${PV}.tar.gz -> ${P}.tar.gz"
Suffix=${PV}
SubDir="plugin-GUI-${PV}"
- S="${WORKDIR}/$SubDir"
+ S="${WORKDIR}/${SubDir}"
KEYWORDS="~amd64 ~x86"
fi
SLOT="${PV}"
IUSE="jack"
-BDEPEND="
- <sys-devel/gcc-9
-"
DEPEND="
media-libs/alsa-lib
media-libs/freeglut
@@ -41,17 +38,17 @@ DEPEND="
x11-libs/libXrandr
x11-libs/libXcursor
x11-libs/libXinerama
- jack? ( media-sound/jack-audio-connection-kit )
+ jack? ( || ( media-sound/jack-audio-connection-kit media-sound/jack2 ) )
"
RDEPEND="${DEPEND}"
-BUILD_DIR="$S/Build"
+BUILD_DIR="${S}/Build"
PATCHES=( "${FILESDIR}"/${P}.patch )
-QA_PREBUILT="opt/open-ephys-0.5.2.2/shared/*.so"
+QA_PREBUILT="opt/open-ephys-*/shared/*.so"
QA_PRESTRIPPED="
- opt/open-ephys-0.5.2.2/plugins/*.so
- opt/open-ephys-0.5.2.2/open-ephys
+ opt/open-ephys-*/plugins/*.so
+ opt/open-ephys-*/open-ephys
"
src_prepare() {
@@ -68,15 +65,16 @@ src_configure() {
}
src_install() {
- dodir opt/open-ephys-"$Suffix"/ lib/udev/rules.d/
- cp -R "${BUILD_DIR}"/Gentoo/* "${ED}"/opt/open-ephys-"$Suffix"/
- cp -R "${WORKDIR}"/"${SubDir}"/Resources/Scripts/40-open-ephys.rules "${ED}"/lib/udev/rules.d/
- dosym ../../opt/open-ephys-"$Suffix"/open-ephys usr/bin/open-ephys-"$Suffix"
+ dodir opt/open-ephys-"${Suffix}"/ lib/udev/rules.d/
+ cp -R "${BUILD_DIR}"/Gentoo/* "${ED}"/opt/open-ephys-"${Suffix}"/
+ udev_newrules "${WORKDIR}"/"${SubDir}"/Resources/Scripts/40-open-ephys.rules 40-open-ephys-"${Suffix}".rules
+ dosym ../../opt/open-ephys-"${Suffix}"/open-ephys usr/bin/open-ephys-"${Suffix}"
}
pkg_postinst() {
- ewarn " "
- ewarn "You must restart the udev service in order to allow your computer to"
- ewarn "communicate with the Open Ephys acquisition board."
- ewarn " "
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
}