aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-biology/cutadapt/Manifest1
-rw-r--r--sci-biology/cutadapt/cutadapt-2.10.ebuild42
-rw-r--r--sci-biology/cutadapt/metadata.xml4
3 files changed, 47 insertions, 0 deletions
diff --git a/sci-biology/cutadapt/Manifest b/sci-biology/cutadapt/Manifest
index ed9f5f70f..f33d6c525 100644
--- a/sci-biology/cutadapt/Manifest
+++ b/sci-biology/cutadapt/Manifest
@@ -1 +1,2 @@
DIST cutadapt-1.9.1.tar.gz 595412 BLAKE2B 379f8c35f1d91b232d76b359187f6f708a0bb6c026a85a678ab49ce13aba2a536b81a181385cfe6e61a5c6b5bac4f5fa73ff5439fff2493966761eb708f0d207 SHA512 9611f3f12e2c99bf03cca2e921e030cafd91782b40e1204e5dc44e4f8b910e2248ddec7e8d394b40460348e8f195ed4fcebc48c018320ce2c3daa1d1722f39c5
+DIST cutadapt-2.10.tar.gz 282198 BLAKE2B 87784fd092d3417775f3a627d68bea1d3421f6392ae90f65e9b5f231f10a4da8cfacecc8c6fc3cd8420d0255ffc44ec72188bc901d1768f18f3b78077a165314 SHA512 afefb101a25daa071e5945e442de46cd594a6f4ba5915e9d11943280039223ff5d686b358de44f11b6367f203767d97b76fc529eae70b072139e55831189e594
diff --git a/sci-biology/cutadapt/cutadapt-2.10.ebuild b/sci-biology/cutadapt/cutadapt-2.10.ebuild
new file mode 100644
index 000000000..e21219dd8
--- /dev/null
+++ b/sci-biology/cutadapt/cutadapt-2.10.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Remove adapter sequences from high-throughput sequencing data"
+HOMEPAGE="https://github.com/marcelm/cutadapt"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-python/dnaio[${PYTHON_USEDEP}]
+ dev-python/xopen[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${PYTHON_DEPS}
+ ${DEPEND}
+"
+BDEPEND="
+ test? (
+ dev-python/cython
+ dev-python/pytest-mock
+ dev-python/pytest-timeout
+ dev-python/sphinx
+ dev-python/sphinx-issues
+ )
+"
+
+distutils_enable_tests pytest
+
+# needs call to installed cutadapt executable
+python_test() {
+ distutils_install_for_testing
+ pytest -vv || die "pytest failed with ${EPYTHON}"
+}
diff --git a/sci-biology/cutadapt/metadata.xml b/sci-biology/cutadapt/metadata.xml
index 6099a3fab..6a2aeb852 100644
--- a/sci-biology/cutadapt/metadata.xml
+++ b/sci-biology/cutadapt/metadata.xml
@@ -5,6 +5,10 @@
<email>mmokrejs@fold.natur.cuni.cz</email>
<name>Martin Mokrejs</name>
</maintainer>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
<maintainer type="project">
<email>sci-biology@gentoo.org</email>
<name>Gentoo Biology Project</name>