aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/umap-learn/umap-learn-0.5.0.ebuild')
-rw-r--r--dev-python/umap-learn/umap-learn-0.5.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/umap-learn/umap-learn-0.5.0.ebuild b/dev-python/umap-learn/umap-learn-0.5.0.ebuild
new file mode 100644
index 000000000..37ca3ca45
--- /dev/null
+++ b/dev-python/umap-learn/umap-learn-0.5.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Uniform Manifold Approximation and Projection"
+HOMEPAGE="https://umap-learn.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/numba[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pynndescent[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ sci-libs/scikit-learn[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+# no tests in package