aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/particle/particle-9999.ebuild')
-rw-r--r--sci-physics/particle/particle-9999.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/sci-physics/particle/particle-9999.ebuild b/sci-physics/particle/particle-9999.ebuild
index 43f1e67ca..e5e49ea91 100644
--- a/sci-physics/particle/particle-9999.ebuild
+++ b/sci-physics/particle/particle-9999.ebuild
@@ -1,6 +1,6 @@
EAPI=8
-PYTHON_COMPAT=( python3_{11..12} )
+PYTHON_COMPAT=( python3_{11..13} )
DISTUTILS_USE_PEP517=hatchling
inherit distutils-r1
@@ -22,12 +22,16 @@ RDEPEND="
>=dev-python/attrs-19.2[${PYTHON_USEDEP}]
>=sci-physics/hepunits-2.0.0[${PYTHON_USEDEP}]
dev-python/deprecated[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.5[${PYTHON_USEDEP}]
+ ' python3_{11..12})
+
"
-DEPEND="${RDEPEND}"
BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
test? (
- >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
dev-python/pandas[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6.0.0[${PYTHON_USEDEP}]
dev-python/tabulate[${PYTHON_USEDEP}]
)
"