summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhasufell <julian.ospald@googlemail.com>2012-04-12 21:41:09 +0200
committerhasufell <julian.ospald@googlemail.com>2012-04-12 21:41:09 +0200
commitdb52a51e2da626fe7dbe9189be3cac2e7cf9b4fb (patch)
treef0f2725b62c26307a07dd61e678e91087997a5f7 /games-strategy
parentgames-strategy/openra: games eclass always last; remove audio-flag from libsdl (diff)
downloadsunrise-reviewed-db52a51e2da626fe7dbe9189be3cac2e7cf9b4fb.tar.gz
sunrise-reviewed-db52a51e2da626fe7dbe9189be3cac2e7cf9b4fb.tar.bz2
sunrise-reviewed-db52a51e2da626fe7dbe9189be3cac2e7cf9b4fb.zip
games-strategy/freesynd: New Ebuild for bug 159251 thanks to Tommy[D]
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/freesynd/ChangeLog10
-rw-r--r--games-strategy/freesynd/Manifest3
-rw-r--r--games-strategy/freesynd/freesynd-9999.ebuild52
-rw-r--r--games-strategy/freesynd/metadata.xml7
4 files changed, 72 insertions, 0 deletions
diff --git a/games-strategy/freesynd/ChangeLog b/games-strategy/freesynd/ChangeLog
new file mode 100644
index 000000000..99fd5f379
--- /dev/null
+++ b/games-strategy/freesynd/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-strategy/freesynd
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*freesynd-9999 (12 Apr 2012)
+
+ 12 Apr 2012; hasufell <julian.ospald@googlemail.com> +freesynd-9999.ebuild,
+ +metadata.xml:
+ New Ebuild for bug 159251 thanks to Tommy[D]
+
diff --git a/games-strategy/freesynd/Manifest b/games-strategy/freesynd/Manifest
new file mode 100644
index 000000000..2fae167db
--- /dev/null
+++ b/games-strategy/freesynd/Manifest
@@ -0,0 +1,3 @@
+EBUILD freesynd-9999.ebuild 1201 RMD160 135b4d85e06bf94e2282e802c54e2c94b791e46a SHA1 572529dda176dd16ec850467505bc0896a6d59c6 SHA256 1b0a88459bf0c977dd68e32e5b08e5f08fb06dc0bdc033575de640c3705f201f
+MISC ChangeLog 297 RMD160 f86a85104bb73ea017b8e432f35890dce0939301 SHA1 6d5e655830c154388ec9ecb8c52050110b6946a1 SHA256 6ca0714d55ca449bca63d9aa19e8750c3511dfd8ae38e80cc5369340d5300299
+MISC metadata.xml 214 RMD160 efd8175069efb91061298ff4584218b633e44678 SHA1 d372fdbfcb7fd07a4082961d3f3527be4fca1d60 SHA256 c1f09dc7d5313cd2da7b82259c7846ed23144d62b15e59680ada90e2b6b4d154
diff --git a/games-strategy/freesynd/freesynd-9999.ebuild b/games-strategy/freesynd/freesynd-9999.ebuild
new file mode 100644
index 000000000..d8f7030b2
--- /dev/null
+++ b/games-strategy/freesynd/freesynd-9999.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+
+inherit cmake-utils eutils subversion games
+
+DESCRIPTION="A cross-platform reimplementation of engine for the classic Bullfrog game, Syndicate"
+HOMEPAGE="http://freesynd.sourceforge.net/"
+ESVN_REPO_URI="https://${PN}.svn.sourceforge.net/svnroot/${PN}/${PN}/trunk"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="media-libs/libogg
+ media-libs/libpng:0
+ media-libs/libsdl[X,audio,video]
+ media-libs/libvorbis
+ media-libs/sdl-mixer[mp3,vorbis]
+ media-libs/sdl-image[png]"
+DEPEND="${RDEPEND}"
+
+CMAKE_IN_SOURCE_BUILD=1
+
+src_prepare() {
+ sed \
+ -e "/freesynd_data_dir/s#/usr/share#${GAMES_DATADIR}#" \
+ -e "/freesynd_data_dir/s/#//" \
+ -i ${PN}.ini || die
+}
+
+src_configure() {
+ cmake-utils_src_configure
+}
+
+src_install() {
+ dogamesbin src/${PN} || die
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data || die
+ newicon icon/sword.png ${PN}.png || die
+ make_desktop_entry ${PN} ${PN} ${PN}
+ dodoc NEWS README INSTALL AUTHORS || die
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "You have to set \"data_dir = /my/path/to/synd-data\""
+ elog "in \"~/.${PN}/${PN}.ini\"."
+}
diff --git a/games-strategy/freesynd/metadata.xml b/games-strategy/freesynd/metadata.xml
new file mode 100644
index 000000000..cc3fe2494
--- /dev/null
+++ b/games-strategy/freesynd/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-wanted@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>