summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Hendrikx (whyscream) <tom@whyscream.net>2012-07-09 23:33:33 +0200
committerTom Hendrikx (whyscream) <tom@whyscream.net>2012-07-09 23:33:33 +0200
commitdbb19e669716d6491f531f63c2e725cee6bb8215 (patch)
tree38f7d4a41b76d8e47fbd751d5d34bb1bd26b7caf /net-dns/nsd/nsd-3.2.11.ebuild
parentx11-plugins/pidgin-window_merge: Version bump for x11-plugins/pidgin-window_m... (diff)
downloadsunrise-reviewed-dbb19e669716d6491f531f63c2e725cee6bb8215.tar.gz
sunrise-reviewed-dbb19e669716d6491f531f63c2e725cee6bb8215.tar.bz2
sunrise-reviewed-dbb19e669716d6491f531f63c2e725cee6bb8215.zip
net-dns/nsd: version bump, new USE flags, and minor init.d fix
Diffstat (limited to 'net-dns/nsd/nsd-3.2.11.ebuild')
-rw-r--r--net-dns/nsd/nsd-3.2.11.ebuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/net-dns/nsd/nsd-3.2.11.ebuild b/net-dns/nsd/nsd-3.2.11.ebuild
new file mode 100644
index 000000000..6ab5454b3
--- /dev/null
+++ b/net-dns/nsd/nsd-3.2.11.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit user versionator
+
+DESCRIPTION="An authoritative only, high performance, open source name server"
+HOMEPAGE="http://www.nlnetlabs.nl/projects/nsd"
+SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bind8-stats ipv6 mmap +nsec3 root-server runtime-checks zone-stats"
+
+RDEPEND="
+ dev-libs/openssl
+ virtual/yacc
+"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/flex
+"
+
+pkg_setup() {
+ enewgroup nsd
+ enewuser nsd -1 -1 -1 nsd
+}
+
+src_configure() {
+ # ebuild.sh sets localstatedir to /var/lib, but nsd expects /var in several locations
+ # some of these cannot be changed by arguments to econf/configure, f.i. logfile
+ econf \
+ --localstatedir="${EPREFIX}/var" \
+ --with-pidfile="${EPREFIX}/var/run/nsd/nsd.pid" \
+ --with-zonesdir="${EPREFIX}/var/lib/nsd" \
+ --enable-largefile \
+ $(use_enable bind8-stats) \
+ $(use_enable ipv6) \
+ $(use_enable mmap) \
+ $(use_enable nsec3) \
+ $(use_enable root-server) \
+ $(use_enable runtime-checks checking) \
+ $(use_enable zone-stats)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc doc/{ChangeLog,CREDITS,NSD-FOR-BIND-USERS,README,RELNOTES,REQUIREMENTS}
+
+ insinto /usr/share/nsd
+ doins contrib/nsd.zones2nsd.conf
+
+ exeinto /etc/cron.daily
+ doexe "${FILESDIR}"/nsd.cron
+
+ newinitd "${FILESDIR}"/nsd.initd nsd
+ newconfd "${FILESDIR}"/nsd.confd nsd
+
+ # database directory, writable by nsd for ixfr.db file
+ dodir /var/db/nsd
+ fowners nsd:nsd /var/db/nsd
+ fperms 750 /var/db/nsd
+
+ # zones directory, writable by root for 'nsdc patch'
+ dodir /var/lib/nsd
+ fowners root:nsd /var/lib/nsd
+ fperms 750 /var/lib/nsd
+
+ # pid dir, writable by nsd
+ dodir /var/run/nsd
+ fowners nsd:nsd /var/run/nsd
+}
+
+pkg_postinst() {
+ version_compare "3.2.9" "${REPLACING_VERSIONS}"
+ if test $? -eq 3; then
+ ewarn "In ${PN}-3.2.9, the database format was changed."
+ ewarn "Please run '/etc/init.d/nsd rebuild' to rebuild the database, then restart nsd."
+ fi
+}